summaryrefslogtreecommitdiff
path: root/dev-libs/crypto++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-libs/crypto++
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/Manifest2
-rw-r--r--dev-libs/crypto++/crypto++-7.0.0-r3.ebuild (renamed from dev-libs/crypto++/crypto++-7.0.0-r2.ebuild)15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-libs/crypto++/Manifest b/dev-libs/crypto++/Manifest
index 5d9c82c946db..ecbb3d6b70bb 100644
--- a/dev-libs/crypto++/Manifest
+++ b/dev-libs/crypto++/Manifest
@@ -3,5 +3,5 @@ AUX crypto++-5.6.5-CVE-2017-9434.patch 1728 BLAKE2B 0cfd25fca89d59486ba9c49a87f0
DIST cryptopp565.zip 4220843 BLAKE2B 0c42da3564cdd175c2f2c5c4272caf826f21e47d2271c7f54acab86f5f79dcdad8d6cb946bc88f55fde6189bb2d24ad8fb03dda6b3b8c6f105434b55b8b217d0 SHA512 f13718d02ca69b0129aaf9e767c9d2e0333aa7538355f9c63d9eaf1ff369062084a18dc01489439ebf37797b3ea81b01beb072057d47ec962bfb824ddc72abc7
DIST cryptopp700.zip 7296665 BLAKE2B 1b1a60e240a9d94b4edfea16beef0ec48ec26c61f7f9a3d89d29bd2e77b13a83ce942f81467bb90d3086253560a3c4acd6b89178dcb416ed4328340ad5222dfd SHA512 8fd8d680e5ceaf10b3c32cb1504bda4b32abc9fcaa2c6e61e3b5e67aca805c792579884bc6a749c29a99105304c421d03d7fe7909fc58f750b3155c7c5cec8ec
EBUILD crypto++-5.6.5-r1.ebuild 1530 BLAKE2B df7d53463e39d86aa3eb905911e5ccdd6cd6ae435b4a51059978b68109c3448c555bbe91984f285671856d5ab7c98232cf2b171d154a01a97655d5aea14cf94b SHA512 f8065ac14fcffa77b75a439edcad34214d62a40184c27f79b073d4f788b2ef3b8667110ef9766d901ed69a25cb1f1639d494f4a0ad2e97391879821569b5a06b
-EBUILD crypto++-7.0.0-r2.ebuild 973 BLAKE2B ae9cbb5042009a6206a8662b6be7da9cb0c2e742aa1f9c8cb4014a9ffc6c080e569c0a5b3c1edce948064714ab619847cc31ed3e569ddcec225f2fef443d3984 SHA512 3bcafbf3ebd72a3e1180aa69ae127392474ddf7ea065edd5435e042d1b2afa1cf5049b5dc29413543f461b0cbfcf7b77998ae7a2f825673d63af20269df09fc2
+EBUILD crypto++-7.0.0-r3.ebuild 1078 BLAKE2B 8ef04dadc10e2cbfa9703682b45a14cc38710c78562f8b8fe649c1908befcc7715d5746b13ab9da56d1526895372bd9d2679ea4137e20d8d354f17b91709ed03 SHA512 b40b4762b563d7b39a15daf4116b4afb10089765f7cca9639876546e2dfe04c672fb67f1cdeb32e796a466ca01d039fea9600e27b4a4b4e3a825e5d68be08835
MISC metadata.xml 597 BLAKE2B 8e8dd9fb9a60f2a5e7fdda6de99b6a07264d54aaa666a41d7fb30da338f91867bdda7135bd21e92191722de7e14ac10f394ac8d8f3118109f4ce6800fb12ebc0 SHA512 e20fd2e76765968417d659a6342ff9229dc822c2291bca00dd6cccd55dc3195563574aaf3a88c68b111821b41c9bce172f4d79bbb462f2b913ab15bcc2c2ee5a
diff --git a/dev-libs/crypto++/crypto++-7.0.0-r2.ebuild b/dev-libs/crypto++/crypto++-7.0.0-r3.ebuild
index 48ed4e46d471..00541d4446d0 100644
--- a/dev-libs/crypto++/crypto++-7.0.0-r2.ebuild
+++ b/dev-libs/crypto++/crypto++-7.0.0-r3.ebuild
@@ -11,26 +11,33 @@ SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
LICENSE="Boost-1.0"
SLOT="0/7" # subslot is so version
-KEYWORDS="alpha amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86 ~x64-macos"
+KEYWORDS="alpha amd64 ~arm arm64 hppa ppc ppc64 ~sparc x86 ~x64-macos"
IUSE="+asm static-libs"
BDEPEND="app-arch/unzip"
S="${WORKDIR}"
+config_uncomment() {
+ sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
+}
+
pkg_setup() {
export CXX="$(tc-getCXX)"
export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
export PREFIX="${EPREFIX}/usr"
}
-src_compile() {
+src_prepare() {
+ default
- use asm || append-cxxflags -DCRYPTOPP_DISABLE_ASM
+ use asm || config_uncomment CRYPTOPP_DISABLE_ASM
# ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
- [[ ${CHOST} == *-darwin* ]] && append-cxxflags -DCRYPTOPP_DISABLE_ASM
+ [[ ${CHOST} == *-darwin* ]] && config_uncomment CRYPTOPP_DISABLE_ASM
+}
+src_compile() {
emake -f GNUmakefile all shared libcryptopp.pc
}