summaryrefslogtreecommitdiff
path: root/dev-libs/cppcodec/cppcodec-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /dev-libs/cppcodec/cppcodec-0.1.ebuild
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'dev-libs/cppcodec/cppcodec-0.1.ebuild')
-rw-r--r--dev-libs/cppcodec/cppcodec-0.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-libs/cppcodec/cppcodec-0.1.ebuild b/dev-libs/cppcodec/cppcodec-0.1.ebuild
deleted file mode 100644
index 8fd88d739a88..000000000000
--- a/dev-libs/cppcodec/cppcodec-0.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils
-
-DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
-HOMEPAGE="https://github.com/tplgy/cppcodec"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"
-
- # Disable pulling in catch
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- virtual/pkgconfig
- >=dev-cpp/catch-2.2.0
- )"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- )
- cmake-utils_src_configure
-}