summaryrefslogtreecommitdiff
path: root/dev-libs/cloog/cloog-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/cloog/cloog-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/cloog/cloog-9999.ebuild')
-rw-r--r--dev-libs/cloog/cloog-9999.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/cloog/cloog-9999.ebuild b/dev-libs/cloog/cloog-9999.ebuild
new file mode 100644
index 000000000000..85781b4d72c3
--- /dev/null
+++ b/dev-libs/cloog/cloog-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/cloog.git"
+ inherit autotools git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-6.0.0[${MULTILIB_USEDEP}]
+ >=dev-libs/isl-0.15:0=[${MULTILIB_USEDEP}]
+ !dev-libs/cloog-ppl"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ ./get_submodules.sh
+ eautoreconf -i
+ else
+ # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
+ # sed to avoid eautoreconf
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
+ fi
+
+ # Make sure we always use the system isl.
+ rm -rf isl
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-gmp=system \
+ --with-isl=system \
+ --with-osl=no \
+ $(use_enable static-libs static)
+}
+
+# The default src_test() fails, so we'll just run these directly
+multilib_src_test () {
+ echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ emake -j1 check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}