summaryrefslogtreecommitdiff
path: root/dev-libs/chmlib/chmlib-0.40-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-libs/chmlib/chmlib-0.40-r1.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-libs/chmlib/chmlib-0.40-r1.ebuild')
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
index bb9a74993b78..957e5d88bca4 100644
--- a/dev-libs/chmlib/chmlib-0.40-r1.ebuild
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit out-of-source
+inherit autotools out-of-source
DESCRIPTION="Library for MS CHM (compressed html) file format"
HOMEPAGE="http://www.jedrea.com/chmlib/"
@@ -19,13 +19,21 @@ PATCHES=(
"${FILESDIR}"/${P}-headers.patch
)
+src_prepare() {
+ default
+ # Required for CONFIG_SHELL != bash (bug #668408)
+ eautoreconf
+}
+
my_src_configure() {
- econf \
- $(use_enable examples) \
+ local myeconfargs=(
+ $(use_enable examples)
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
my_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}