summaryrefslogtreecommitdiff
path: root/dev-libs/chmlib/chmlib-0.40-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/chmlib/chmlib-0.40-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/chmlib/chmlib-0.40-r1.ebuild')
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
new file mode 100644
index 000000000000..88496bdb5c54
--- /dev/null
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Library for MS CHM (compressed html) file format"
+HOMEPAGE="http://www.jedrea.com/chmlib/"
+SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 x86"
+IUSE="+examples static-libs"
+
+DOCS=(AUTHORS NEWS README)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39-stdtypes.patch
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_configure() {
+ myeconfargs=($(use_enable examples))
+ autotools-utils_src_configure
+}