summaryrefslogtreecommitdiff
path: root/dev-libs/chmlib/chmlib-0.40-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /dev-libs/chmlib/chmlib-0.40-r1.ebuild
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'dev-libs/chmlib/chmlib-0.40-r1.ebuild')
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
index 88496bdb5c54..f1e56dc52863 100644
--- a/dev-libs/chmlib/chmlib-0.40-r1.ebuild
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Library for MS CHM (compressed html) file format"
HOMEPAGE="http://www.jedrea.com/chmlib/"
@@ -14,13 +14,18 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 x86"
IUSE="+examples static-libs"
-DOCS=(AUTHORS NEWS README)
PATCHES=(
"${FILESDIR}"/${PN}-0.39-stdtypes.patch
"${FILESDIR}"/${P}-headers.patch
)
-src_configure() {
- myeconfargs=($(use_enable examples))
- autotools-utils_src_configure
+my_src_configure() {
+ econf \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+my_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
}