summaryrefslogtreecommitdiff
path: root/dev-libs/cgreen/cgreen-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/cgreen/cgreen-1.3.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/cgreen/cgreen-1.3.0.ebuild')
-rw-r--r--dev-libs/cgreen/cgreen-1.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/cgreen/cgreen-1.3.0.ebuild b/dev-libs/cgreen/cgreen-1.3.0.ebuild
new file mode 100644
index 000000000000..1b1189420def
--- /dev/null
+++ b/dev-libs/cgreen/cgreen-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Unit test and mocking framework for C and C++"
+HOMEPAGE="https://cgreen-devs.github.io/"
+SRC_URI="https://github.com/cgreen-devs/cgreen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/glibc:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ #Patch to fix git directory detection see https://github.com/cgreen-devs/cgreen/issues/234
+ "${FILESDIR}/${P}-cmake-git.patch"
+)