summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/capstone-4.0.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/capstone/capstone-4.0.2-r2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/capstone/capstone-4.0.2-r2.ebuild')
-rw-r--r--dev-libs/capstone/capstone-4.0.2-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/capstone/capstone-4.0.2-r2.ebuild b/dev-libs/capstone/capstone-4.0.2-r2.ebuild
new file mode 100644
index 000000000000..99f181cb326c
--- /dev/null
+++ b/dev-libs/capstone/capstone-4.0.2-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils distutils-r1 toolchain-funcs
+
+DESCRIPTION="disassembly/disassembler framework + bindings"
+HOMEPAGE="http://www.capstone-engine.org/"
+SRC_URI="https://github.com/aquynh/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/4" # libcapstone.so.4
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RESTRICT="!test? ( test )"
+
+IUSE="python static-libs test"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S=${WORKDIR}/${P/_rc/-rc}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libsuffix.patch
+)
+
+wrap_python() {
+ if use python; then
+ pushd bindings/python >/dev/null || die
+ distutils-r1_${1} "$@"
+ popd >/dev/null
+ fi
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ wrap_python ${FUNCNAME}
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCAPSTONE_BUILD_TESTS="$(usex test)"
+ -DCAPSTONE_BUILD_STATIC="$(usex static-libs)"
+ )
+ cmake-utils_src_configure
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ wrap_python ${FUNCNAME}
+}
+
+src_test() {
+ cmake-utils_src_test
+
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ wrap_python ${FUNCNAME}
+}