summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/capstone-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-libs/capstone/capstone-4.0.1.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-libs/capstone/capstone-4.0.1.ebuild')
-rw-r--r--dev-libs/capstone/capstone-4.0.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/capstone/capstone-4.0.1.ebuild b/dev-libs/capstone/capstone-4.0.1.ebuild
index e4931c690d0d..77b9b960a583 100644
--- a/dev-libs/capstone/capstone-4.0.1.ebuild
+++ b/dev-libs/capstone/capstone-4.0.1.ebuild
@@ -16,7 +16,9 @@ LICENSE="BSD"
SLOT="0/4" # libcapstone.so.4
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="python"
+RESTRICT="!test? ( test )"
+
+IUSE="python test"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
@@ -63,6 +65,11 @@ src_configure() {
EOF
} >> config.mk || die
+ if ! use test; then
+ # Don't build tests if not requested: bug #663006
+ sed -i tests/Makefile -e 's@all: $(BINARY)@all:@' || die
+ fi
+
wrap_python ${FUNCNAME}
}