summaryrefslogtreecommitdiff
path: root/dev-libs/botan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/botan
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest3
-rw-r--r--dev-libs/botan/botan-2.18.0.ebuild164
2 files changed, 167 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index a87f58fcccec..c3cfdb2d1c5f 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,3 +1,6 @@
DIST Botan-2.17.3.tar.xz 5937596 BLAKE2B 605e71c959889b459bc26f17d310a33f26c9a51fe00db91db407ac5b96c9ff57bef67a401f71826e83e0d4eda2289c22685957289e6bb357f3693a1bce60f44d SHA512 ead0f144dfb9eca66d0e81e376d0d49f4b0b6bc1599f8cf52299e1753645b5b20100efa004ef5f9571f7bea88958f35db38367fc26f2603890f8f199cc890dbc
+DIST Botan-2.18.0.tar.xz 5941536 BLAKE2B 2a4182bab5e681fdfeafa113462bf5a31057d7be97d71d0a6e60975b84432dd3932498f42f0b879e216727df4bbfcbf0d844e971df95eaf9cf922280f32858b4 SHA512 8613412e3e2fe8b787db7a4d4dbadf60b8fe6b68a84408c600c37cd0b5dbdf3f347a49f5bd88eb8d4f658e927a8b976884146551bf7d256fa80e9675297c0f09
+DIST Botan-2.18.0.tar.xz.asc 488 BLAKE2B b9a9c98e11eae227fb900cae2dca3aecc2114ecacd87336cf5cdbe6fbcb9676514f11e365e94dbfecf3b9edc1a9a3398ff2c66f34a77d7b4d6b0f87518af6d9a SHA512 f2e1689e10b0706eed5a3cf08dfcb163874d3ada12968ac739eeff259ae81b1329fafdae4d29290195276fe3bb1cdeaf3f302b8df53a377c5bbdb7964deaa044
EBUILD botan-2.17.3.ebuild 3099 BLAKE2B 218965706fb7d39380d3268bd416c2a35cec007fe9e4e8102a009e020716c00f4e2a930e681095d2bce998d277db2c280f051693652f95115285628b8028a2ed SHA512 968d68556f6203cdbe818514469ba59b5001375efd844177c9f036cb954e2caa833d08f7c34efa3912599093af08ff7a38e631db8c3c85ca7e666ed177b02dec
+EBUILD botan-2.18.0.ebuild 4100 BLAKE2B 388b70639710cbdf6505461e1acd287df83b87eb900f8b5801063790cf4f35e2d613b530575cf82edb6d1e93477731be9c8beae8831dfcaa908b17ef414fcf8d SHA512 0dc9b8f915e892a9d93e9374668f1df49bbdb7f6aff04f3fc3dea54d93df307428ae1a491b0f28e579716b8d796680ce0dc084185ad71ac0932aadfcb8cd29a6
MISC metadata.xml 518 BLAKE2B e3816e408031bfaa81f090f9c4d47027827a5b89ccde82cde859efb76200ae443f4c71b83d548fbe9329bbae620112ee59d6882a41df7eb60361f6de1085346b SHA512 ec0f64495b54f912e44a0a2cfda063a136452e0fba33268d645fbafedb4fba41713debc0219d2c68eeffde27fd0b74580465e50d160187e417defc36b61033a3
diff --git a/dev-libs/botan/botan-2.18.0.ebuild b/dev-libs/botan/botan-2.18.0.ebuild
new file mode 100644
index 000000000000..4d9fc251745d
--- /dev/null
+++ b/dev-libs/botan/botan-2.18.0.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/botan.asc"
+inherit python-r1 toolchain-funcs verify-sig
+
+MY_P="Botan-${PV}"
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+SRC_URI+=" verify-sig? ( https://botan.randombit.net/releases/${MY_P}.tar.xz.asc )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="2/$(ver_cut 1-2)" # soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="bindist doc boost bzip2 lzma python ssl static-libs sqlite zlib"
+
+CPU_USE=(
+ cpu_flags_arm_{aes,neon}
+ cpu_flags_ppc_altivec
+ cpu_flags_x86_{aes,avx2,popcnt,rdrand,sse2,ssse3,sse4_1,sse4_2}
+)
+
+IUSE+=" ${CPU_USE[@]}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? ( dev-libs/openssl:0=[bindist=] )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+ verify-sig? ( app-crypt/openpgp-keys-botan )
+"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ local disable_modules=(
+ $(usex boost '' 'boost')
+ $(usex bindist 'ecdsa' '')
+ )
+
+ if [[ -z "${DISABLE_MODULES}" ]] ; then
+ elog "Disabling module(s): ${disable_modules[@]}"
+ fi
+
+ local chostarch="${CHOST%%-*}"
+
+ # Arch specific wrangling
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*)
+ myos=darwin
+ ;;
+
+ *)
+ myos=linux
+
+ if [[ ${CHOST} == *hppa* ]] ; then
+ chostarch=parisc
+ elif [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+ ;;
+
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ local myargs=(
+ # Intrinsics
+ # TODO: x86 RDSEED (new CPU_FLAGS_X86?)
+ # TODO: POWER Crypto (new CPU_FLAGS_PPC?)
+ $(usex cpu_flags_arm_aes '' '--disable-armv8crypto')
+ $(usex cpu_flags_arm_neon '' '--disable-neon')
+ $(usex cpu_flags_ppc_altivec '' '--disable-altivec')
+ $(usex cpu_flags_x86_aes '' '--disable-aes-ni')
+ $(usex cpu_flags_x86_avx2 '' '--disable-avx2')
+ $(usex cpu_flags_x86_popcnt '' '--disable-bmi2')
+ $(usex cpu_flags_x86_rdrand '' '--disable-rdrand')
+ $(usex cpu_flags_x86_sse2 '' '--disable-sse2')
+ $(usex cpu_flags_x86_ssse3 '' '--disable-ssse3')
+ $(usex cpu_flags_x86_sse4_1 '' '--disable-sse4.1')
+ $(usex cpu_flags_x86_sse4_2 '' '--disable-sse4.2')
+
+ $(usex hppa --without-stack-protector '')
+
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_enable static-libs static-library)
+ $(use_with ssl openssl)
+ $(use_with sqlite sqlite3)
+ $(use_with zlib)
+
+ --cpu=${chostarch}
+ --docdir=share/doc
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --distribution-info="Gentoo ${PVR}"
+ --libdir=$(get_libdir)
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ --no-install-python-module
+
+ --os=${myos}
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ )
+
+ tc-export CC CXX AR
+
+ ./configure.py "${myargs[@]}" || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}