summaryrefslogtreecommitdiff
path: root/dev-libs/boehm-gc/boehm-gc-7.2e.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/boehm-gc/boehm-gc-7.2e.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-7.2e.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.2e.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.2e.ebuild b/dev-libs/boehm-gc/boehm-gc-7.2e.ebuild
deleted file mode 100644
index 02c94d5ed7c8..000000000000
--- a/dev-libs/boehm-gc/boehm-gc-7.2e.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-MY_P="gc-${PV/_/}"
-
-DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
-HOMEPAGE="http://www.hboehm.info/gc/"
-SRC_URI="http://www.hboehm.info/gc/gc_source/${MY_P}.tar.gz"
-
-LICENSE="boehm-gc"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cxx static-libs threads"
-
-DEPEND=">=dev-libs/libatomic_ops-7.2
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P/e}"
-
-src_prepare() {
- rm -r libatomic_ops || die
-
- epatch "${FILESDIR}"/${P}-automake-1.13.patch
- eautoreconf
-}
-
-src_configure() {
- local config=(
- --with-libatomic-ops
- $(use_enable cxx cplusplus)
- $(use_enable static-libs static)
- $(use threads || echo --disable-threads)
- )
- econf "${config[@]}"
-}
-
-src_install() {
- default
-
- rm -r "${ED}"/usr/share/gc || die
-
- # dist_noinst_HEADERS
- insinto /usr/include/gc
- doins include/{cord.h,ec.h,javaxfc.h}
- insinto /usr/include/gc/private
- doins include/private/*.h
-
- dodoc README.QUICK doc/README{.environment,.linux,.macros} doc/barrett_diagram
- dohtml doc/*.html
- newman doc/gc.man GC_malloc.1
-
- use static-libs || prune_libtool_files #457872
-}