summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild')
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
new file mode 100644
index 000000000000..120faea56d6a
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.57-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-Werror-CFLAG.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}