summaryrefslogtreecommitdiff
path: root/dev-libs/appstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/appstream
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/appstream')
-rw-r--r--dev-libs/appstream/Manifest2
-rw-r--r--dev-libs/appstream/appstream-0.12.6.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index ca2e61272897..b3809d524f80 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,5 +1,7 @@
DIST AppStream-0.12.3.tar.xz 1940064 BLAKE2B a0160c4a922abfe315bdbfe6b7b32fea8d5eda5631347be4a39dcf102660ad26a3f40c5fed9dd0bdfb1b91956780ff7cf58e61d7f38b03d2f48a5bf67f2871f6 SHA512 3d54bb499e4056d341ffde2878549011708e6699b3ec58756ef2e4080864279ff5e5003224fcbad601007fd9296bb9ed062da7843e3e02272837ecc5d4c802f9
DIST AppStream-0.12.4.tar.xz 1944416 BLAKE2B 3a315b167084f9f6d8f50a86fa2853444a12beb63e3c7e77bf97c861e1a31dd7fd5ff9c4406d0da1b551b1fbb366531740cd4efdde354b857613507c06eabe62 SHA512 8a7a10b0c577a22b89e0b5505415d5b799f3316b4c87b0a2a9281e7b2672e041225896ac847781504b2828c5ed8a250e3a0558355df838d58e174a984b04e3d0
+DIST AppStream-0.12.6.tar.xz 1953604 BLAKE2B 28b03a935b8c203f2ac2c52c1de8317cc899f2b81b00e83e2eb858dbd185a985ce608ba3f6b1c35f084b4ee91946a4870c89d6b0c0a4c6fd32a938558e3997f1 SHA512 c19cd89ba39aff5afa2ff6d5fca72581a8624463c33011b11036526db98392ff5aa6c0f599682e90fdee29b8732538cf96c20b66965016b96f60b3f899d722bb
EBUILD appstream-0.12.3.ebuild 1454 BLAKE2B f8bed2ff11275869ee9658151aa92d1b96ef3fa140a976d62ba417537c5b7fa2030f9189253f084f754bb42442e4b673a325fa7c75290e9652e8d543f2d7dd66 SHA512 82d1b5f662065ba4d14a0b065324cd99335d2fa7a8ef6aed20256ffe8b88207cf989cc604cc2459cefca4a02836c127fcfba150287fdb30af3a456552e7a8293
EBUILD appstream-0.12.4.ebuild 1571 BLAKE2B adafb3c31f13e991d6c665169c5ac1ab986d7bcfdd1462aebe2b431ac7823dedd28a7bbdc1ab8b5786bb020a47a3dcc05b137e01b23169d227046097740be5c5 SHA512 41000771c6651d3a90a9aef13186222c5950543350fe2037c03963116baead8c5463c465674bfb8180a5e902b1564bab9c6ca113ba5cb42586895407d2b36f97
+EBUILD appstream-0.12.6.ebuild 1580 BLAKE2B 9e0c51d995ae99df8a2e39ba57595dd1d707230c01ba35d03b8807ebfefe808a96c4d7c332c6aa0061ab19d95624a9c623e8c8d7ddab0aaed34734895bd94df5 SHA512 15a9365e9ea4a87c8b8de3dd0c4789be28c4cffbee2fb4b8936144e29020e0c91446c8b0f87756f148ab70477d5a8bf7b417313deb55bbdfc065a75990a9c8b0
MISC metadata.xml 399 BLAKE2B 433fcfbb840f3efc4130de1a4b9a18ce3b1762363bfa67d994a063098da0397b6776a6154250ad5a35a4960241234f2ba3dc2464b760cf19cbb680590d559049 SHA512 1f81f3603fc34a3dbeb570fe83ed2ff97e4ea2391cda7d7ceef017624a8498052cda4a21dee1f6b8eb41407998dfcecd765bde556837d00b13caaa41989f934f
diff --git a/dev-libs/appstream/appstream-0.12.6.ebuild b/dev-libs/appstream/appstream-0.12.6.ebuild
new file mode 100644
index 000000000000..2b8019ab0684
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.12.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ MY_PN="AppStream"
+ SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt +introspection qt5 test"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=dev-util/meson-0.42.0
+ >=sys-devel/gettext-0.19.8
+ test? (
+ dev-qt/linguist-tools:5
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+DEPEND="
+ >=dev-libs/glib-2.54:2
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ qt5? ( dev-qt/qtcore:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+ if ! use test; then
+ sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Dapidocs=false
+ -Ddocs=false
+ -Dmaintainer=false
+ -Dstemming=true
+ -Dvapi=false
+ -Dapt-support=$(usex apt true false)
+ -Dgir=$(usex introspection true false)
+ -Dqt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}