summaryrefslogtreecommitdiff
path: root/dev-libs/appstream/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-libs/appstream/files
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-libs/appstream/files')
-rw-r--r--dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch14
-rw-r--r--dev-libs/appstream/files/appstream-0.12.2-gcc-7.3.patch24
2 files changed, 24 insertions, 14 deletions
diff --git a/dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch b/dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch
deleted file mode 100644
index 2a37662e8f34..000000000000
--- a/dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Gentoo-bug: https://bugs.gentoo.org/640916
-Thanks-to: David Haller <gentoo@dhaller.de>
-
---- a/po/meson.build 2017-09-04 18:09:52.000000000 +0200
-+++ b/po/meson.build 2018-05-15 12:24:42.000000000 +0200
-@@ -21,7 +21,7 @@
- 'find ' + meson.current_source_dir() +
- ' -type f' +
- ' -iname "*.po"' +
-- ' -printf \'%f\\n\'' +
-+ ' -printf \'%f\n\'' +
- ' | grep -oP \'.*(?=[.])\' | sort' +
- ' > ' + join_paths(meson.current_source_dir(), 'LINGUAS')
- ]
diff --git a/dev-libs/appstream/files/appstream-0.12.2-gcc-7.3.patch b/dev-libs/appstream/files/appstream-0.12.2-gcc-7.3.patch
new file mode 100644
index 000000000000..3eb8b0db877d
--- /dev/null
+++ b/dev-libs/appstream/files/appstream-0.12.2-gcc-7.3.patch
@@ -0,0 +1,24 @@
+From 9252de815e4443d1b617211f38685afe7c0f6b0e Mon Sep 17 00:00:00 2001
+From: Matthias Klumpp <matthias@tenstral.net>
+Date: Sat, 20 Oct 2018 20:20:09 +0200
+Subject: [PATCH] Explicitly include string.h in as-tag.c
+
+This apparently is necessary to fix an FTBFS issue with older GCC
+releases. Resolves #207
+---
+ src/as-tag.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/as-tag.c b/src/as-tag.c
+index 6afba621..91076e69 100644
+--- a/src/as-tag.c
++++ b/src/as-tag.c
+@@ -32,6 +32,8 @@
+
+ #include "as-tag.h"
+
++#include <string.h>
++
+ #ifdef __clang__
+ #pragma clang diagnostic ignored "-Wmissing-field-initializers"
+ #endif