summaryrefslogtreecommitdiff
path: root/dev-libs/aml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/aml
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/aml')
-rw-r--r--dev-libs/aml/Manifest4
-rw-r--r--dev-libs/aml/aml-0.2.1.ebuild40
-rw-r--r--dev-libs/aml/aml-9999.ebuild20
3 files changed, 59 insertions, 5 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
index dddc0d826d47..71b3ae531eaa 100644
--- a/dev-libs/aml/Manifest
+++ b/dev-libs/aml/Manifest
@@ -1,4 +1,6 @@
DIST aml-0.2.0.tar.gz 20358 BLAKE2B 4be63726ea9069cbfe36fbf04e3a0b2229066d7df039aea1a41fdca27700d012fda9eda348115f8c0ef9d3f201640123722d0b96bc7b171841d920357a292152 SHA512 196cd891fdbaad47340d8b4ca9eb62a7f9e6b0969ae9ad744a3c9ea110a532691d53a1e39fde583bad0f8fdae4b51c3a4243bbdab65e952e5fc79ceb6efc3262
+DIST aml-0.2.1.tar.gz 20413 BLAKE2B 62f8cc0e75f23ac7dc8835dd874f584cdb5b394b0d7af08feded06b99ccff66395e0ec04bdd26917ef7784457dc170c2c99bc98a118ecff947602e4d9a60bf21 SHA512 0af4a50cafbddd2a593dac437e6c8121de5265d0383139818bcda97d672a7430cb410ce32552b6842bc82eaebb061bc6cc0ee1b45a483754efbdfbc2103fa2e3
EBUILD aml-0.2.0.ebuild 547 BLAKE2B 69e6def9bcd3f4cd7c1974f37e1d82a5cd27d0dda1844d101f9561eac3c97b6ca02f41a78d7e48002749b83c6595ec62e3e921ceca4b33d0575be26b3b701e27 SHA512 62b1069313afe519ae724d78e6fef94a7427a31e5faa2d5924c972d5b9b684b689c5b1beab181c88ab26daeb351c3c2f7af838e69707917d54323cece303f70f
-EBUILD aml-9999.ebuild 535 BLAKE2B 3ab2c148d97b733405e6ae622681e48834944564f0fcb7306337938440205765c1c45d16e9dfbddcd9f9dc85d99a0c093090fd4d45e3647e6b3f869a673774be SHA512 ee09a25d9331fe35d9f867780b05aadc03f18fa53ebb70fd69f6782e187dc7829f1112366b198fdbfb810147de3498ca3c4a3570caab942551f506a0925b018e
+EBUILD aml-0.2.1.ebuild 781 BLAKE2B 84ef1a03bef5871649d70370a596a4581d1c925a4db5513217b6ebb904cb9a16951c45a6fc0f5832499bdee77f9e5e112b2471916d91377df131accb0fad0f3d SHA512 f7dbebee00b2692cf4d617c4d5863c28ab37160bfa2f250b3061c192bdf6a6cf8739b3b2a18138c3a1d99036f25a3684c5427e4ebc217ffc1f7961f6c3f74c60
+EBUILD aml-9999.ebuild 781 BLAKE2B 84ef1a03bef5871649d70370a596a4581d1c925a4db5513217b6ebb904cb9a16951c45a6fc0f5832499bdee77f9e5e112b2471916d91377df131accb0fad0f3d SHA512 f7dbebee00b2692cf4d617c4d5863c28ab37160bfa2f250b3061c192bdf6a6cf8739b3b2a18138c3a1d99036f25a3684c5427e4ebc217ffc1f7961f6c3f74c60
MISC metadata.xml 241 BLAKE2B 846f82e50a664313c50b12a55e75e373c741f992d300613e78ff61acacc9c26ce73fd9fc3d8e195eabc2fb3ce8f4b327b667e02f96cc7937c3d8d2805c80768e SHA512 65d4acc3b715ff5e9929bee91adeebae522449519fc091cbdaa3afd74bdb36cb7f8f13d96ca7e95757ad9e66ace68727ca96940a4187ece4c7821a5f8992e64e
diff --git a/dev-libs/aml/aml-0.2.1.ebuild b/dev-libs/aml/aml-0.2.1.ebuild
new file mode 100644
index 000000000000..5ff10f20992d
--- /dev/null
+++ b/dev-libs/aml/aml-0.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index db62c0b53724..5ff10f20992d 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
-DESCRIPTION="event timer executor loop"
+DESCRIPTION="Event timer executor loop"
HOMEPAGE="https://github.com/any1/aml/"
if [[ ${PV} == 9999 ]]; then
@@ -13,16 +13,28 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="ISC"
SLOT="0"
IUSE="examples"
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use examples)
)
+
meson_src_configure
}