summaryrefslogtreecommitdiff
path: root/dev-libs/aml/aml-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/aml/aml-9999.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/aml/aml-9999.ebuild')
-rw-r--r--dev-libs/aml/aml-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index db62c0b53724..5ff10f20992d 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
-DESCRIPTION="event timer executor loop"
+DESCRIPTION="Event timer executor loop"
HOMEPAGE="https://github.com/any1/aml/"
if [[ ${PV} == 9999 ]]; then
@@ -13,16 +13,28 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="ISC"
SLOT="0"
IUSE="examples"
+DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+
+src_prepare() {
+ default
+
+ # The bundled copy includes cdefs which breaks on musl and
+ # this header is already available on glibc.
+ # bug #828806
+ rm include/sys/queue.h || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use examples)
)
+
meson_src_configure
}