summaryrefslogtreecommitdiff
path: root/dev-libs/OpenNI2/OpenNI2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 23:56:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 23:56:06 +0000
commit038c98389fa5a5efb22cffaa35ecdddfc9a38036 (patch)
tree04bae6b07cc56a603b9bb571367fda8181244b2b /dev-libs/OpenNI2/OpenNI2-9999.ebuild
parent3392d5e937023e57811edc670b0ed7d3aba55c6d (diff)
gentoo auto-resync : 15:01:2023 - 23:56:06
Diffstat (limited to 'dev-libs/OpenNI2/OpenNI2-9999.ebuild')
-rw-r--r--dev-libs/OpenNI2/OpenNI2-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/OpenNI2/OpenNI2-9999.ebuild b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
index ffd87acd6445..2c75c2c95808 100644
--- a/dev-libs/OpenNI2/OpenNI2-9999.ebuild
+++ b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/occipital/openni2"
fi
-inherit ${SCM} toolchain-funcs java-pkg-opt-2
+inherit ${SCM} flag-o-matic toolchain-funcs java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -52,6 +52,12 @@ src_prepare() {
}
src_compile() {
+ if ! use elibc_glibc ; then
+ # Build system doesn't respect CPPFLAGS.
+ # bug #716346
+ append-flags -DXN_PLATFORM_LINUX_NO_GLIBC -DXN_PLATFORM_HAS_NO_SCHED_PARAM
+ fi
+
use cpu_flags_arm_neon && export CFLAGS="${CFLAGS} -DXN_NEON"
emake \
CC="$(tc-getCC)" \