summaryrefslogtreecommitdiff
path: root/dev-libs/OpenNI2/OpenNI2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
commitbd8ca999980e9c0c9ae40a11789c858bb58769e3 (patch)
tree355d68a84921e04a81231e74fc062f229f76a733 /dev-libs/OpenNI2/OpenNI2-9999.ebuild
parentb3f2504c1d05b5999b74b2135860fc721e3adf68 (diff)
gentoo auto-resync : 15:07:2022 - 13:42:19
Diffstat (limited to 'dev-libs/OpenNI2/OpenNI2-9999.ebuild')
-rw-r--r--dev-libs/OpenNI2/OpenNI2-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/OpenNI2/OpenNI2-9999.ebuild b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
index 210a3efeea3a..ffd87acd6445 100644
--- a/dev-libs/OpenNI2/OpenNI2-9999.ebuild
+++ b/dev-libs/OpenNI2/OpenNI2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/occipital/openni2"
fi
-inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2 flag-o-matic
+inherit ${SCM} toolchain-funcs java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -23,12 +23,12 @@ DESCRIPTION="OpenNI2 SDK"
HOMEPAGE="https://structure.io/openni"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="doc java neon opengl static-libs"
+IUSE="cpu_flags_arm_neon doc java opengl static-libs"
RDEPEND="
+ media-libs/libjpeg-turbo:=
virtual/libusb:1
virtual/libudev
- virtual/jpeg:0
opengl? ( media-libs/freeglut )
java? ( virtual/jre:1.8 )
"
@@ -52,7 +52,7 @@ src_prepare() {
}
src_compile() {
- use neon && export CFLAGS="${CFLAGS} -DXN_NEON"
+ use cpu_flags_arm_neon && export CFLAGS="${CFLAGS} -DXN_NEON"
emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \