summaryrefslogtreecommitdiff
path: root/dev-libs/OpenNI/files/tinyxml.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/OpenNI/files/tinyxml.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/OpenNI/files/tinyxml.patch')
-rw-r--r--dev-libs/OpenNI/files/tinyxml.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/OpenNI/files/tinyxml.patch b/dev-libs/OpenNI/files/tinyxml.patch
new file mode 100644
index 000000000000..801cabbd7708
--- /dev/null
+++ b/dev-libs/OpenNI/files/tinyxml.patch
@@ -0,0 +1,29 @@
+Index: OpenNI-9999/Platform/Linux/Build/OpenNI/Makefile
+===================================================================
+--- OpenNI-9999.orig/Platform/Linux/Build/OpenNI/Makefile
++++ OpenNI-9999/Platform/Linux/Build/OpenNI/Makefile
+@@ -4,13 +4,11 @@ BIN_DIR = ../../Bin
+
+ INC_DIRS = \
+ ../../../../Include \
+- ../../../../Source \
+- ../../../../Externals/TinyXml
++ ../../../../Source
+
+ SRC_FILES = \
+ ../../../../Source/OpenNI/*.cpp \
+- ../../../../Source/OpenNI/Linux/*.cpp \
+- ../../../../Externals/TinyXml/*.cpp
++ ../../../../Source/OpenNI/Linux/*.cpp
+
+ ifeq ("$(OSTYPE)","Darwin")
+ INC_DIRS += /opt/local/include
+@@ -19,7 +17,7 @@ ifeq ("$(OSTYPE)","Darwin")
+ endif
+
+ LIB_NAME = OpenNI
+-USED_LIBS = usb-1.0 dl pthread
++USED_LIBS = usb-1.0 dl pthread tinyxml
+ ifneq ("$(OSTYPE)","Darwin")
+ USED_LIBS += rt
+ endif