summaryrefslogtreecommitdiff
path: root/dev-libs/OpenNI/OpenNI-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
commit83b5cde41ddb8fd20de4536dd68eb08da42d013e (patch)
tree6a993cfe0eb5a8024c508e9f6a6de02538f7c52e /dev-libs/OpenNI/OpenNI-9999.ebuild
parent9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (diff)
gentoo auto-resync : 17:07:2022 - 20:32:17
Diffstat (limited to 'dev-libs/OpenNI/OpenNI-9999.ebuild')
-rw-r--r--dev-libs/OpenNI/OpenNI-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-libs/OpenNI/OpenNI-9999.ebuild b/dev-libs/OpenNI/OpenNI-9999.ebuild
index 0febb7dba0b7..a200d7f1be3e 100644
--- a/dev-libs/OpenNI/OpenNI-9999.ebuild
+++ b/dev-libs/OpenNI/OpenNI-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/OpenNI/OpenNI"
fi
-inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2
+inherit ${SCM} flag-o-matic toolchain-funcs java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -26,16 +26,16 @@ SLOT="0"
IUSE="doc java opengl"
RDEPEND="
+ media-libs/libjpeg-turbo:=
virtual/libusb:1
virtual/libudev
- virtual/jpeg:0
dev-libs/tinyxml
opengl? ( media-libs/freeglut !dev-libs/OpenNI2[opengl] )
java? ( virtual/jre:1.8 )
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
java? ( virtual/jdk:1.8 )"
+BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}/tinyxml.patch"
@@ -56,6 +56,9 @@ src_prepare() {
}
src_compile() {
+ # bug #855671
+ append-flags -fno-strict-aliasing
+
emake -C "${S}/Platform/Linux/Build" \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \