summaryrefslogtreecommitdiff
path: root/dev-lang/zig/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-lang/zig/files
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-lang/zig/files')
-rw-r--r--dev-lang/zig/files/zig-0.9.1-fix-bad-hostname-segfault.patch26
-rw-r--r--dev-lang/zig/files/zig-0.9.1-fix-clang16.patch23
-rw-r--r--dev-lang/zig/files/zig-0.9.1-fix-riscv.patch47
-rw-r--r--dev-lang/zig/files/zig-0.9.1-fix-single-threaded.patch13
4 files changed, 0 insertions, 109 deletions
diff --git a/dev-lang/zig/files/zig-0.9.1-fix-bad-hostname-segfault.patch b/dev-lang/zig/files/zig-0.9.1-fix-bad-hostname-segfault.patch
deleted file mode 100644
index 2e87ecc6d6ee..000000000000
--- a/dev-lang/zig/files/zig-0.9.1-fix-bad-hostname-segfault.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://github.com/ziglang/zig/commit/601d8f721d6dc90ac390bf5ecc7d8bafdd6a30d8
-Bug https://bugs.gentoo.org/829959
-
-From 601d8f721d6dc90ac390bf5ecc7d8bafdd6a30d8 Mon Sep 17 00:00:00 2001
-From: Veikka Touminen <git@vexu.eu>
-Date: Sun, 10 Jul 2022 04:27:23 -0600
-Subject: [PATCH] std.net.getAddressList: fix segfault on bad hostname
-
-Fixes #12065
----
- lib/std/net.zig | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/std/net.zig b/lib/std/net.zig
-index 235ad8496a1..c381df9bce7 100644
---- a/lib/std/net.zig
-+++ b/lib/std/net.zig
-@@ -731,7 +731,7 @@ pub fn getAddressList(allocator: mem.Allocator, name: []const u8, port: u16) !*A
- break :blk result;
- };
- const arena = result.arena.allocator();
-- errdefer result.arena.deinit();
-+ errdefer result.deinit();
-
- if (builtin.target.os.tag == .windows or builtin.link_libc) {
- const name_c = try std.cstr.addNullByte(allocator, name);
diff --git a/dev-lang/zig/files/zig-0.9.1-fix-clang16.patch b/dev-lang/zig/files/zig-0.9.1-fix-clang16.patch
deleted file mode 100644
index deb563378d76..000000000000
--- a/dev-lang/zig/files/zig-0.9.1-fix-clang16.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Eric Joldasov <bratishkaerik@getgoogleoff.me>
-Fix building with Clang 16
-Upstream PR https://github.com/ziglang/zig/pull/13121
-
---- a/src/stage1/parse_f128.c
-+++ b/src/stage1/parse_f128.c
-@@ -983,14 +983,14 @@ static int isspace(int c)
- return c == ' ' || (unsigned)c-'\t' < 5;
- }
-
--static inline float128_t makeInf128() {
-+static inline float128_t makeInf128(void) {
- union ldshape ux;
- ux.i2.hi = 0x7fff000000000000UL;
- ux.i2.lo = 0x0UL;
- return ux.f;
- }
-
--static inline float128_t makeNaN128() {
-+static inline float128_t makeNaN128(void) {
- uint64_t rand = 0UL;
- union ldshape ux;
- ux.i2.hi = 0x7fff000000000000UL | (rand & 0xffffffffffffUL);
diff --git a/dev-lang/zig/files/zig-0.9.1-fix-riscv.patch b/dev-lang/zig/files/zig-0.9.1-fix-riscv.patch
deleted file mode 100644
index 372a68ea02ad..000000000000
--- a/dev-lang/zig/files/zig-0.9.1-fix-riscv.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-https://github.com/ziglang/zig/commit/ca3c4ff2d0afcdc8fe86e7e7b41a967c88779729
-From: Shupei Fan <dymarkfan@outlook.com>
-zig0: properly set llvm_cpu_names and llvm_cpu_features for riscv
-
-Bug: https://bugs.gentoo.org/851732
-
---- a/src/stage1/zig0.cpp
-+++ b/src/stage1/zig0.cpp
-@@ -160,6 +160,17 @@ static void get_native_target(ZigTarget *target) {
- }
- }
-
-+static const char* get_baseline_llvm_cpu_name(ZigLLVM_ArchType arch) {
-+ return "";
-+}
-+
-+static const char* get_baseline_llvm_cpu_features(ZigLLVM_ArchType arch) {
-+ switch (arch) {
-+ case ZigLLVM_riscv64: return "+a,+c,+d,+m";
-+ default: return "";
-+ }
-+}
-+
- static Error target_parse_triple(struct ZigTarget *target, const char *zig_triple, const char *mcpu,
- const char *dynamic_linker)
- {
-@@ -178,8 +189,8 @@ static Error target_parse_triple(struct ZigTarget *target, const char *zig_tripl
- } else if (strcmp(mcpu, "baseline") == 0) {
- target->is_native_os = false;
- target->is_native_cpu = false;
-- target->llvm_cpu_name = "";
-- target->llvm_cpu_features = "";
-+ target->llvm_cpu_name = get_baseline_llvm_cpu_name(target->arch);
-+ target->llvm_cpu_features = get_baseline_llvm_cpu_features(target->arch);
- } else {
- const char *msg = "stage0 can't handle CPU/features in the target";
- stage2_panic(msg, strlen(msg));
-@@ -220,6 +231,9 @@ static Error target_parse_triple(struct ZigTarget *target, const char *zig_tripl
- const char *msg = "stage0 can't handle CPU/features in the target";
- stage2_panic(msg, strlen(msg));
- }
-+
-+ target->llvm_cpu_name = get_baseline_llvm_cpu_name(target->arch);
-+ target->llvm_cpu_features = get_baseline_llvm_cpu_features(target->arch);
- }
-
- return ErrorNone;
diff --git a/dev-lang/zig/files/zig-0.9.1-fix-single-threaded.patch b/dev-lang/zig/files/zig-0.9.1-fix-single-threaded.patch
deleted file mode 100644
index 70f807f2d550..000000000000
--- a/dev-lang/zig/files/zig-0.9.1-fix-single-threaded.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 638f39f7e..791477c41 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -787,7 +787,7 @@ else()
- set(ZIG1_RELEASE_ARG -OReleaseFast --strip)
- endif()
- if(ZIG_SINGLE_THREADED)
-- set(ZIG1_SINGLE_THREADED_ARG "-fsingle-threaded")
-+ set(ZIG1_SINGLE_THREADED_ARG "--single-threaded")
- else()
- set(ZIG1_SINGLE_THREADED_ARG "")
- endif()