summaryrefslogtreecommitdiff
path: root/dev-lang/zig-bin/zig-bin-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /dev-lang/zig-bin/zig-bin-0.10.0.ebuild
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'dev-lang/zig-bin/zig-bin-0.10.0.ebuild')
-rw-r--r--dev-lang/zig-bin/zig-bin-0.10.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/zig-bin/zig-bin-0.10.0.ebuild b/dev-lang/zig-bin/zig-bin-0.10.0.ebuild
new file mode 100644
index 000000000000..45c577eadde5
--- /dev/null
+++ b/dev-lang/zig-bin/zig-bin-0.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A robust, optimal, and maintainable programming language"
+HOMEPAGE="https://ziglang.org/"
+SRC_URI="
+ amd64? ( https://ziglang.org/download/${PV}/zig-linux-x86_64-${PV}.tar.xz )
+ arm? ( https://ziglang.org/download/${PV}/zig-linux-armv7a-${PV}.tar.xz )
+ arm64? ( https://ziglang.org/download/${PV}/zig-linux-aarch64-${PV}.tar.xz )
+ riscv? ( https://ziglang.org/download/${PV}/zig-linux-riscv64-${PV}.tar.xz )
+ x86? ( https://ziglang.org/download/${PV}/zig-linux-i386-${PV}.tar.xz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="!dev-lang/zig"
+# Zig provides its standard library in source form "/opt/zig-bin-{PV}/lib/",
+# and all other Zig libraries are meant to be consumed in source form,
+# because they can use compile-time mechanics (and it is easier for distributions to patch them)
+# Here we use this feature for fixing programs that use standard library
+# Note: Zig build system is also part of standard library, so we can fix it too
+#PATCHES=( )
+
+QA_PREBUILT="opt/${P}/zig"
+
+src_unpack() {
+ unpack ${A}
+
+ mv "${WORKDIR}/"* "${S}"
+}
+
+src_install() {
+ insinto /opt/
+ doins -r "${S}"
+
+ dosym -r /opt/${P}/doc/ /usr/share/doc/${PF}
+ dosym -r /opt/${P}/zig /usr/bin/zig
+ fperms 0755 /usr/bin/zig
+}
+
+pkg_postinst() {
+ elog "0.10.0 release introduces self-hosted compiler for general use by default"
+ elog "It means that your code can be un-compilable since this compiler has some new or removed features and new or fixed bugs"
+ elog "Upstream recommends using stage1 if experiencing such breakage,"
+ elog "until bugfix release 0.10.1 or release 0.11.0 where old compiler will be fully replaced"
+ elog "You can use old compiler by using '-fstage1' flag"
+ elog "Also see: https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler"
+ elog "and https://ziglang.org/download/0.10.0/release-notes.html#How-to-Upgrade"
+}