summaryrefslogtreecommitdiff
path: root/dev-lang/yasm/yasm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/yasm/yasm-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/yasm/yasm-9999.ebuild')
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
deleted file mode 100644
index 19cd65988740..000000000000
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils python-r1
-
-if [[ ${PV} == 9999* ]] ; then
- EGIT_REPO_URI="https://github.com/yasm/yasm.git"
- inherit git-r3
-else
- SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
-fi
-
-DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
-HOMEPAGE="http://yasm.tortall.net/"
-
-LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
-SLOT="0"
-IUSE="nls python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
-
-if [[ ${PV} == 9999* ]]; then
- DEPEND="${DEPEND} ${PYTHON_DEPS} app-text/xmlto app-text/docbook-xml-dtd:4.1.2"
-fi
-
-src_prepare() {
- if ! [[ ${PV} == 9999* ]]; then
- sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
- fi
- # ksh doesn't grok $(xxx), makes aclocal fail
- sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
- eautoreconf
-
- if [[ ${PV} == 9999* ]]; then
- ./modules/arch/x86/gen_x86_insn.py || die
- fi
-}
-
-src_configure() {
- if [[ ${PV} == 9999* ]]; then
- python_export_best
- else
- use python && python_export_best
- fi
-
- econf \
- --disable-warnerror \
- $(use_enable python) \
- $(use_enable python python-bindings) \
- $(use_enable nls)
-}
-
-src_test() {
- emake check
-}