summaryrefslogtreecommitdiff
path: root/dev-lang/yasm/yasm-1.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-lang/yasm/yasm-1.3.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-lang/yasm/yasm-1.3.0-r1.ebuild')
-rw-r--r--dev-lang/yasm/yasm-1.3.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-lang/yasm/yasm-1.3.0-r1.ebuild b/dev-lang/yasm/yasm-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..ffd88e2bc667
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.3.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/yasm/yasm.git"
+ inherit autotools git-r3
+else
+ SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://yasm.tortall.net/"
+
+LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
+SLOT="0"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ nls? ( virtual/libintl )
+"
+RDEPEND="${DEPEND}
+"
+
+if [[ ${PV} == 9999* ]]; then
+ BDEPEND+="
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ dev-lang/python
+ "
+fi
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999* ]]; then
+ eautoreconf
+ python modules/arch/x86/gen_x86_insn.py || die
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ CCLD_FOR_BUILD="$(tc-getBUILD_CC)"
+ --disable-warnerror
+ --disable-python
+ --disable-python-bindings
+ $(use_enable nls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # https://bugs.gentoo.org/718870
+ emake -j1 check
+}