summaryrefslogtreecommitdiff
path: root/dev-lang/tcc/tcc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-20 11:17:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-20 11:17:21 +0000
commit48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (patch)
treef88035a58c20099cf45a576fb53b0330a4754f14 /dev-lang/tcc/tcc-9999.ebuild
parent0fb71e0215ed52863e462cccef73c01aff44d43d (diff)
gentoo resync : 20.12.2017
Diffstat (limited to 'dev-lang/tcc/tcc-9999.ebuild')
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index 728ed94dbec7..d55542ed7b7e 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,17 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
-inherit eutils toolchain-funcs git-r3
+EAPI="6"
DESCRIPTION="A very small C compiler for ix86/amd64"
HOMEPAGE="http://bellard.org/tcc/"
-EGIT_REPO_URI="http://repo.or.cz/r/tinycc.git"
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="http://repo.or.cz/r/tinycc.git"
+ KEYWORDS=""
+ SRC_URI=""
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ SRC_URI="http://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
+fi
+
+inherit toolchain-funcs ${scm_eclass}
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
DEPEND="dev-lang/perl" # doc generation
# Both tendra and tinycc install /usr/bin/tcc
@@ -32,6 +40,8 @@ src_prepare() {
# fix texi2html invocation
sed -i -e 's/-number//' Makefile || die
sed -i -e 's/--sections//' Makefile || die
+
+ eapply_user
}
src_configure() {