summaryrefslogtreecommitdiff
path: root/dev-lang/swig/swig-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-lang/swig/swig-4.1.1.ebuild
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-lang/swig/swig-4.1.1.ebuild')
-rw-r--r--dev-lang/swig/swig-4.1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lang/swig/swig-4.1.1.ebuild b/dev-lang/swig/swig-4.1.1.ebuild
new file mode 100644
index 000000000000..76be84b0a4f5
--- /dev/null
+++ b/dev-lang/swig/swig-4.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/ https://github.com/swig/swig"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ BSD BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ccache doc pcre test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre2 )
+ ccache? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/boost )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
+
+src_configure() {
+ econf \
+ PKGCONFIG="$(tc-getPKG_CONFIG)" \
+ $(use_enable ccache) \
+ $(use_with pcre)
+}
+
+src_test() {
+ # The tests won't get run w/o an explicit call, broken Makefiles?
+ emake check
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto html
+ dodoc -r Doc/{Devel,Manual}
+ fi
+}