summaryrefslogtreecommitdiff
path: root/dev-lang/solidity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /dev-lang/solidity
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'dev-lang/solidity')
-rw-r--r--dev-lang/solidity/Manifest6
-rw-r--r--dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff15
-rw-r--r--dev-lang/solidity/files/solidity-0.4.2-commit_hash.txt1
-rw-r--r--dev-lang/solidity/solidity-0.4.18.ebuild37
-rw-r--r--dev-lang/solidity/solidity-0.4.2.ebuild38
5 files changed, 55 insertions, 42 deletions
diff --git a/dev-lang/solidity/Manifest b/dev-lang/solidity/Manifest
index c37ddcb291a8..b61ff514f917 100644
--- a/dev-lang/solidity/Manifest
+++ b/dev-lang/solidity/Manifest
@@ -1,4 +1,4 @@
-AUX solidity-0.4.2-commit_hash.txt 9 BLAKE2B 34c6552f84854047ae6aea393db49418cbbef86bc37a0a3c58e21a0b358f7b3177807bda8fd5b81af405fc34a55bdab52525ada3d21a014abf8bb6b9fe3c0800 SHA512 766569e9ffb283e6efbb81dc546502df8b294a445713392ae9717a845a014f3170c29448d3d7256256b4e467c7c6ea9d9eba45c83ec68c7798a2c67d1cab3033
-DIST solidity-0.4.2.tar.gz 495039 BLAKE2B ee09fc457d64727468eedb3d9150ad123f8e7cbfe80a71de0a730f43bd3b0b71f2ceb01ba189b542e273cfe4c1bccef3f0e0c5077512992c058729f52fded015 SHA512 2ef2e58775e22eefce867ee73dbab61f54def1edd95e089ec3a388b5aaba316c44fe18b92d45e070014b9df6e450b2b27fe78434f5db40f0476c505b2541572c
-EBUILD solidity-0.4.2.ebuild 1023 BLAKE2B 69544d30dcde700079bf1e5a143ecc95e0650f49cee7c7a7a40f9d285530ef0f678d10d644f981552cfb374eb4078749ae28a2faa330e6f4712c9074370490fb SHA512 cd7095e9f5c54d3ef42b568ebe019ef337ac64e52f4d6b6041548d964ce39384ed4cdbdb3d3c58f4a061f87dbeb6e1966b7052431ec95a1bd6bc86f619024e6e
+AUX solidity-0.4.18-fix-cmake-external-jsoncpp.diff 378 BLAKE2B 00e8ae9719e3d7faaf22ff806793ccd47222e4eee34e8528327396dbeb0333a723e5a8959513f980c11a8d7d5fab57fe07a06226b3ec398c201911db65e1bf60 SHA512 44b76b9dd9a1cd37c4fcf39d7aa585873ed9b394d54b0d862b6909dbe905d2202e1d2a9ef0e84e959931b0805d6f049c6567ad424f9561229803768ceafad4ff
+DIST solidity-0.4.18.tar.gz 1005571 BLAKE2B b7748f1e9ceb260ee5c02a5e6ddb7a3387a6f1df252889258045cf03e3cab365f1ac41c7e75805a49b71beceb88439855c53b6c59a81d610db48f9fe5256da55 SHA512 aa88060567a50fa833a81ef2c9ce9614ed0fddd9dc82c1546998dacd9a7cad1863882aa0700d830f80fe52bd91659a9fa07434af193624206876ba7224c34eb7
+EBUILD solidity-0.4.18.ebuild 766 BLAKE2B cbba8496a179b2f273efa677f82749ce0b6bca2e2e642c7d01579c9c59ae14233ee80e3ff017f35bb9257cd3f43bbe518d92e14ef7a2f7e76692ed10d52bd12e SHA512 a6a19af46537d59bf273e9a031250fc57d1f743296fd02416c9289921f201d0c98129714d2b6212fddc4bfa8be2f5ca102b77e190c06bb088266b17dad47a42f
MISC metadata.xml 450 BLAKE2B 43358d0df6ec754300e4e95ef6cf3abd0702ab121cd70c58bc7808ee3d47346c5a42843ce895b1a9974bba8ed9716ba5256cd74a31343ac2fc29f4ef60196232 SHA512 8de6f5dadccb7020d6fbbd17a3800dd9a44e4b19f484e38799fd00b240fbd2a4d213454eb7cec2d99ab8ea7834fe5a0d3f792c62420870e55986b2978af9789d
diff --git a/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff b/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff
new file mode 100644
index 000000000000..1acafc9d9e36
--- /dev/null
+++ b/dev-lang/solidity/files/solidity-0.4.18-fix-cmake-external-jsoncpp.diff
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 24bea3b3..4326927b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,7 +18,9 @@ include(EthCcache)
+
+ # Let's find our dependencies
+ include(EthDependencies)
+-include(jsoncpp)
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(JSONCPP jsoncpp)
++include_directories("${JSONCPP_INCLUDE_DIRS}")
+
+ find_package(Threads)
+
diff --git a/dev-lang/solidity/files/solidity-0.4.2-commit_hash.txt b/dev-lang/solidity/files/solidity-0.4.2-commit_hash.txt
deleted file mode 100644
index fd2779b63759..000000000000
--- a/dev-lang/solidity/files/solidity-0.4.2-commit_hash.txt
+++ /dev/null
@@ -1 +0,0 @@
-af6afb04
diff --git a/dev-lang/solidity/solidity-0.4.18.ebuild b/dev-lang/solidity/solidity-0.4.18.ebuild
new file mode 100644
index 000000000000..8a36d44a9092
--- /dev/null
+++ b/dev-lang/solidity/solidity-0.4.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="The Solidity Contract-Oriented Programming Language"
+HOMEPAGE="https://github.com/ethereum/solidity"
+SRC_URI="https://github.com/ethereum/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-libs/jsoncpp-1.8.1:=
+ >=dev-libs/boost-1.54:=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Upstream downloads and builds a static jsoncpp during build
+ "${FILESDIR}"/${P}-fix-cmake-external-jsoncpp.diff
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBoost_USE_STATIC_LIBS=off"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-lang/solidity/solidity-0.4.2.ebuild b/dev-lang/solidity/solidity-0.4.2.ebuild
deleted file mode 100644
index 7deebb0fb767..000000000000
--- a/dev-lang/solidity/solidity-0.4.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="The Solidity Contract-Oriented Programming Language"
-HOMEPAGE="https://github.com/ethereum/solidity"
-SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/jsoncpp:=
- dev-libs/boost:=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # The build won't work without this file but it is missing from
- # the release tarball.
- #
- # Reported upstream: https://github.com/ethereum/solidity/issues/1183
-
- cp "${FILESDIR}"/${P}-commit_hash.txt "${S}"/commit_hash.txt || die "Could not copy commit hash"
-
- # Without this file the build is marked as a developer version
- # but it is missing from the release tarball.
- #
- # Reported upstream: https://github.com/ethereum/solidity/issues/1183
-
- touch "${S}"/prerelease.txt || die "Could not mark as release version"
-}