summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.65.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
commit7bd77a6744e2cd6d203240181996a998985e0288 (patch)
tree75dc88e47dcab0692b84f1b2684ffa9fde351aff /dev-lang/rust/rust-1.65.0.ebuild
parentc33b50e5d2446c439465ff4575253db72ef2b8f6 (diff)
gentoo auto-resync : 26:11:2022 - 01:13:45
Diffstat (limited to 'dev-lang/rust/rust-1.65.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index bfc942995c50..2306e80be316 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rls rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
@@ -126,7 +126,6 @@ RDEPEND="${DEPEND}
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
miri? ( nightly )
parallel-compiler? ( nightly )
- rls? ( rust-src )
rust-analyzer? ( !wasm )
test? ( ${ALL_LLVM_TARGETS[*]} )
wasm? ( llvm_targets_WebAssembly )
@@ -208,7 +207,6 @@ pre_build_checks() {
fi
M=$(( $(usex clippy 128 0) + ${M} ))
M=$(( $(usex miri 128 0) + ${M} ))
- M=$(( $(usex rls 512 0) + ${M} ))
M=$(( $(usex rustfmt 256 0) + ${M} ))
# add 2G if we compile llvm and 256M per llvm_target
if ! use system-llvm; then
@@ -331,9 +329,8 @@ src_configure() {
use clippy && tools+=',"clippy"'
use miri && tools+=',"miri"'
use profiler && tools+=',"rust-demangler"'
- use rls && tools+=',"rls","analysis"'
use rustfmt && tools+=',"rustfmt"'
- use rust-analyzer && tools+=',"rust-analyzer"'
+ use rust-analyzer && tools+=',"rust-analyzer","analysis"'
use rust-src && tools+=',"src"'
local rust_stage0_root
@@ -658,7 +655,6 @@ src_install() {
use clippy && symlinks+=( clippy-driver cargo-clippy )
use miri && symlinks+=( miri cargo-miri )
use profiler && symlinks+=( rust-demangler )
- use rls && symlinks+=( rls )
use rustfmt && symlinks+=( rustfmt cargo-fmt )
use rust-analyzer && symlinks+=( rust-analyzer )
@@ -719,9 +715,6 @@ src_install() {
if use profiler; then
echo /usr/bin/rust-demangler >> "${T}/provider-${P}"
fi
- if use rls; then
- echo /usr/bin/rls >> "${T}/provider-${P}"
- fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"