summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.32.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /dev-lang/rust/rust-1.32.0.ebuild
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'dev-lang/rust/rust-1.32.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index bc2a6106b8ad..73715829cfaa 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -5,6 +5,8 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+LLVM_MAX_SLOT=7
+
inherit check-reqs eapi7-ver estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
if [[ ${PV} = *beta* ]]; then
@@ -45,7 +47,7 @@ COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/libssh2
net-libs/http-parser:=
net-misc/curl[ssl]
- system-llvm? ( >=sys-devel/llvm-7:= )"
+ system-llvm? ( sys-devel/llvm:7= )"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
@@ -65,6 +67,9 @@ PATCHES=(
"${FILESDIR}"/1.30.1-clippy-sysroot.patch
"${FILESDIR}"/1.32.0-fix-configure-of-bundled-llvm.patch
"${FILESDIR}"/1.32.0-system-llvm-7-SIGSEGV.patch
+ # Support LibreSSL 2.8.x: https://github.com/sfackler/rust-openssl/commit/9fd7584a84168655cb27e03b7e19a9847b88e77f
+ # Support LibreSSL 2.9.0: https://github.com/sfackler/rust-openssl/commit/af4488357c9b3e003b883e89c16aaa675ad0c6ac
+ "${FILESDIR}"/1.32.0-libressl.patch
)
toml_usex() {
@@ -138,6 +143,7 @@ src_configure() {
release-debuginfo = $(toml_usex debug)
assertions = $(toml_usex debug)
targets = "${LLVM_TARGETS// /;}"
+ experimental-targets = ""
link-shared = $(toml_usex system-llvm)
[build]
build = "${rust_target}"
@@ -184,7 +190,7 @@ src_configure() {
EOF
if use system-llvm; then
cat <<- EOF >> "${S}"/config.toml
- llvm-config = "$(get_llvm_prefix)/bin/llvm-config"
+ llvm-config = "$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
EOF
fi
done