summaryrefslogtreecommitdiff
path: root/dev-lang/ruby/ruby-2.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-lang/ruby/ruby-2.6.5.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-lang/ruby/ruby-2.6.5.ebuild')
-rw-r--r--dev-lang/ruby/ruby-2.6.5.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-lang/ruby/ruby-2.6.5.ebuild b/dev-lang/ruby/ruby-2.6.5.ebuild
index 57bd24dcd4f5..563576964c50 100644
--- a/dev-lang/ruby/ruby-2.6.5.ebuild
+++ b/dev-lang/ruby/ruby-2.6.5.ebuild
@@ -142,19 +142,18 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
# Makefile is broken because it lacks -ldl
rm -rf ext/-test-/popen_deadlock || die
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS="" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS=""
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -194,7 +193,7 @@ src_install() {
local gem_home="${EPREFIX}/usr/$(get_libdir)/ruby/gems/${RUBYVERSION}"
mkdir -p "${D}/${gem_home}" || die "mkdir gem home failed"
- emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install || die "make install failed"
+ emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -203,7 +202,7 @@ src_install() {
rm -rf "${ED}/usr/bin/"{bundle,bundler,ri,rdoc}"${MY_SUFFIX}" || die "rm rdoc bins failed"
if use doc; then
- emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc || die "make install-doc failed"
+ emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc
fi
if use examples; then
@@ -211,7 +210,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test