summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec-conf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-lang/python-exec-conf
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-lang/python-exec-conf')
-rw-r--r--dev-lang/python-exec-conf/Manifest3
-rw-r--r--dev-lang/python-exec-conf/metadata.xml8
-rw-r--r--dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild40
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-lang/python-exec-conf/Manifest b/dev-lang/python-exec-conf/Manifest
new file mode 100644
index 000000000000..c05ea706bd8f
--- /dev/null
+++ b/dev-lang/python-exec-conf/Manifest
@@ -0,0 +1,3 @@
+DIST python-exec-2.4.6.tar.bz2 87634 BLAKE2B 7b6de8ad0e0603fafd3284e6e3c5247ad83f145ab4db6728914318ae8e6f5aaa3c0247f4e01238fca11519ef72fb1b11436aea7e2b8c988b8717b3f6a2a43c37 SHA512 e05eaf01b83de196a10933636ab6b1a5489a421592df49b8b58eabd0e732de970f902744cd3a06b5ab530a6d69fe6dfa8f270fbb09b9fe3df4ae04d516828050
+EBUILD python-exec-conf-2.4.6.ebuild 1168 BLAKE2B b2ba54c0b6f2e4f0f62c3f3e4769b378eed563831975065b69154efbeac4597f9d5b101bf1b32af427f601050bb881dd68bff48d65cbebe4b11d79e2d02c5996 SHA512 302786afebe1b7ab62d800be280976c1790be8de3157e7ec8ffae36491c9682ebdb8e9a02eadbd39cdf715e7a1c7f600b2726c540525645c93cf8c30802fcada
+MISC metadata.xml 240 BLAKE2B 97c523cb7da7b4b1e2c1809fadbe80a88f0760dd98356fc1b9a1d8f7514fb8a696f1d36bc45285a3dc169994c78176d2bcf1397df51f9e3227c7b2dff5849742 SHA512 57181dfbeaab954ce3f81beb68ef3458f78d2f1fb9c9c2954e0553d19806b3455721f8845eb45beccd79a20941f682487fa0e09763339012a4b5057ed4e2a524
diff --git a/dev-lang/python-exec-conf/metadata.xml b/dev-lang/python-exec-conf/metadata.xml
new file mode 100644
index 000000000000..aa2793060bf8
--- /dev/null
+++ b/dev-lang/python-exec-conf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild b/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild
new file mode 100644
index 000000000000..db918e82c65e
--- /dev/null
+++ b/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit python-utils-r1
+
+MY_P=${P/-conf}
+DESCRIPTION="Configuration file for dev-lang/python-exec"
+HOMEPAGE="https://github.com/mgorny/python-exec/"
+SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_}"
+
+RDEPEND="!<dev-lang/python-exec-2.4.6-r4"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ local pyimpls=() i EPYTHON
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
+ if use "python_targets_${i}"; then
+ _python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
+ fi
+ done
+
+ # Prepare and own the template
+ insinto /etc/python-exec
+ newins - python-exec.conf \
+ < <(sed -n -e '/^#/p' config/python-exec.conf.example &&
+ printf '%s\n' "${pyimpls[@]}" | tac)
+}