summaryrefslogtreecommitdiff
path: root/dev-lang/polyml/polyml-5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/polyml/polyml-5.6.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/polyml/polyml-5.6.ebuild')
-rw-r--r--dev-lang/polyml/polyml-5.6.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-lang/polyml/polyml-5.6.ebuild b/dev-lang/polyml/polyml-5.6.ebuild
deleted file mode 100644
index 6cdf4fdd6fb5..000000000000
--- a/dev-lang/polyml/polyml-5.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools pax-utils
-
-DESCRIPTION="Poly/ML is a full implementation of Standard ML"
-HOMEPAGE="https://www.polyml.org"
-SRC_URI="https://codeload.github.com/polyml/polyml/tar.gz/v${PV} -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="X elibc_glibc +gmp portable test +threads"
-
-RDEPEND="X? ( x11-libs/motif:0 )
- gmp? ( >=dev-libs/gmp-5 )
- elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
- virtual/libffi"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- --disable-static \
- --with-system-libffi \
- $(use_with X x) \
- $(use_with gmp) \
- $(use_with portable) \
- $(use_with threads)
-}
-
-src_compile() {
- # Bug 453146 - dev-lang/polyml-5.5.0: fails to build (pax kernel?)
- pushd libpolyml || die "Could not cd to libpolyml"
- emake
- popd
- emake polyimport
- pax-mark m "${S}/.libs/polyimport"
- emake
- pax-mark m "${S}/.libs/poly"
-}
-
-src_test() {
- emake tests || die "tests failed"
-}