summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
commitfb7c221776ce0bda5eb40ef32cb74daa98aed0d7 (patch)
tree0da74e27cfe965ce494b4be29eb9b4d04dda8259 /dev-lang/php/php-8.3.4.ebuild
parent7e8f29e487b79a183d66ca22f1e54dab5c47a409 (diff)
gentoo auto-resync : 09:04:2024 - 18:31:35
Diffstat (limited to 'dev-lang/php/php-8.3.4.ebuild')
-rw-r--r--dev-lang/php/php-8.3.4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-lang/php/php-8.3.4.ebuild b/dev-lang/php/php-8.3.4.ebuild
index f4f263225218..7242d6432c71 100644
--- a/dev-lang/php/php-8.3.4.ebuild
+++ b/dev-lang/php/php-8.3.4.ebuild
@@ -146,6 +146,7 @@ PHP_MV="$(ver_cut 1)"
PATCHES=(
"${FILESDIR}/php-iodbc-header-location.patch"
+ "${FILESDIR}/fix-musl-llvm.patch"
)
# ARM/Windows functions (bug 923335)
@@ -267,6 +268,12 @@ src_prepare() {
# https://github.com/php/php-src/pull/13017
#
rm ext/dom/tests/DOMNode_isEqualNode.phpt || die
+
+ # This is a memory usage test with hard-coded limits. Whenever the
+ # limits are surpassed... they get increased... but in the meantime,
+ # the tests fail. This is not really a test that end users should
+ # be running pre-install, in my opinion. Bug 927461.
+ rm ext/fileinfo/tests/bug78987.phpt || die
}
src_configure() {