summaryrefslogtreecommitdiff
path: root/dev-lang/ocaml/ocaml-4.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-lang/ocaml/ocaml-4.11.2.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-lang/ocaml/ocaml-4.11.2.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-4.11.2.ebuild b/dev-lang/ocaml/ocaml-4.11.2.ebuild
index 280d813184b1..e3298bdfc899 100644
--- a/dev-lang/ocaml/ocaml-4.11.2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit flag-o-matic
+
HOMEPAGE="https://ocaml.org/"
SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
@@ -21,6 +23,15 @@ PDEPEND="emacs? ( app-emacs/ocaml-mode )
src_prepare() {
default
+
+ # OCaml generates textrels on 32-bit arches
+ # We can't do anything about it, but disabling it means that tests
+ # for OCaml-based packages won't fail on unexpected output
+ # bug #773226
+ #if use arm || use ppc || use x86 ; then
+ append-ldflags "-Wl,-z,notext"
+ #fi
+
# Upstream build ignores LDFLAGS in several places.
sed -i -e 's/\(^MKDLL=.*\)/\1 $(LDFLAGS)/' \
-e 's/\(^OC_CFLAGS=.*\)/\1 $(LDFLAGS)/' \