summaryrefslogtreecommitdiff
path: root/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-lang/ocaml/ocaml-4.05.0-r3.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r3.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
index ecf884d0ff1a..69094b6cb10a 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic eutils multilib toolchain-funcs
+inherit flag-o-matic multilib toolchain-funcs
PATCHLEVEL="9"
MY_P="${P/_/-}"
@@ -49,9 +49,8 @@ pkg_setup() {
}
src_prepare() {
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ EPATCH_SUFFIX="patch" eapply "${WORKDIR}/patches"
default
-
}
src_configure() {
@@ -67,6 +66,14 @@ src_configure() {
# -ggdb3 & co makes it behave weirdly, breaks sexplib
replace-flags -ggdb* -ggdb
+ # OCaml generates textrels on 32-bit arches
+ # We can't do anything about it, but disabling it means that tests
+ # for OCaml-based packages won't fail on unexpected output
+ # bug #773226
+ if use arm || use ppc || use x86 ; then
+ append-ldflags "-Wl,-z,notext"
+ fi
+
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"