summaryrefslogtreecommitdiff
path: root/dev-lang/nqp/nqp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-lang/nqp/nqp-9999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-lang/nqp/nqp-9999.ebuild')
-rw-r--r--dev-lang/nqp/nqp-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/nqp/nqp-9999.ebuild b/dev-lang/nqp/nqp-9999.ebuild
index 6adbdc268327..120648d125d4 100644
--- a/dev-lang/nqp/nqp-9999.ebuild
+++ b/dev-lang/nqp/nqp-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit java-pkg-opt-2 multibuild
@@ -10,8 +10,7 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
KEYWORDS=""
else
- SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
- inherit vcs-snapshot
+ SRC_URI="https://github.com/perl6/${PN}/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -30,10 +29,11 @@ CDEPEND="java? (
)
moar? ( ~dev-lang/moarvm-${PV}[clang=] )"
RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.8 )"
+DEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
+ java? ( >=virtual/jdk-1.8 )
dev-lang/perl"
pkg_pretend() {
@@ -70,7 +70,7 @@ nqp_configure() {
pushd "${BUILD_DIR}" > /dev/null || die
local myconfargs=(
"--backend=${MULTIBUILD_VARIANT}"
- "--prefix=/usr" )
+ "--prefix=${EPREFIX%/}/usr" )
perl Configure.pl "${myconfargs[@]}" || die
popd || die