summaryrefslogtreecommitdiff
path: root/dev-lang/neko/neko-2.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 02:11:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 02:11:03 +0100
commit21005a6009e62933ab3199ef84aef68f82b2b8d7 (patch)
tree51dec0ed7236ef9feb3563cb54700e631815cee0 /dev-lang/neko/neko-2.3.0-r1.ebuild
parent944b3df0f275eea0fd7808913d72a0b280df0c33 (diff)
gentoo auto-resync : 07:08:2022 - 02:11:02
Diffstat (limited to 'dev-lang/neko/neko-2.3.0-r1.ebuild')
-rw-r--r--dev-lang/neko/neko-2.3.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/neko/neko-2.3.0-r1.ebuild b/dev-lang/neko/neko-2.3.0-r1.ebuild
index c078c06afa2c..701f48537ec9 100644
--- a/dev-lang/neko/neko-2.3.0-r1.ebuild
+++ b/dev-lang/neko/neko-2.3.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit flag-o-matic cmake
DESCRIPTION="Neko is a high-level dynamically typed programming language"
HOMEPAGE="https://nekovm.org/"
@@ -38,6 +38,10 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ # -Werror=strict-aliasing warnings, bug #855641
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local mycmakeargs=(
-DRUN_LDCONFIG=OFF
-DWITH_NEKOML=ON