summaryrefslogtreecommitdiff
path: root/dev-lang/nasm/nasm-2.16.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /dev-lang/nasm/nasm-2.16.01.ebuild
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'dev-lang/nasm/nasm-2.16.01.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.16.01.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.16.01.ebuild b/dev-lang/nasm/nasm-2.16.01.ebuild
new file mode 100644
index 000000000000..0516affa1974
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.16.01.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-code-pro
+ media-fonts/source-sans:3
+ virtual/perl-File-Spec
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+)
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/870214
+ # During the split of media-fonts/source-pro, the source-sans files
+ # were renamed. Currently depend on media-fonts/source-sans:3 which works
+ # with this sed.
+ sed -i 's/SourceSansPro/SourceSans3/g' doc/psfonts.ph || die
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install $(usex doc install_doc '')
+}