summaryrefslogtreecommitdiff
path: root/dev-lang/mozart/mozart-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-lang/mozart/mozart-2.0.1.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-lang/mozart/mozart-2.0.1.ebuild')
-rw-r--r--dev-lang/mozart/mozart-2.0.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/mozart/mozart-2.0.1.ebuild b/dev-lang/mozart/mozart-2.0.1.ebuild
index d469901f25b6..510d6729b40b 100644
--- a/dev-lang/mozart/mozart-2.0.1.ebuild
+++ b/dev-lang/mozart/mozart-2.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake java-pkg-2 java-ant-2
+inherit cmake elisp-common java-pkg-2 java-ant-2
PATCHSET_VER="1"
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
dev-lang/scala:2.12
test? ( dev-cpp/gtest:= )"
+SITEFILE="50${PN}-gentoo.el"
+
S="${WORKDIR}/${PN}2-${PV}"
src_prepare() {
@@ -71,12 +73,19 @@ src_install() {
dolib.so "${BUILD_DIR}"/vm/vm/main/libmozartvm.so
dolib.so "${BUILD_DIR}"/vm/boostenv/main/libmozartvmboost.so
+
+ if use emacs; then
+ elisp-install ${PN} "${S}"/opi/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/"${SITEFILE}" \
+ || die "elsip-site-file-install failed"
+ fi
}
pkg_postinst() {
if use emacs; then
xdg_icon_cache_update
xdg_desktop_database_update
+ elisp-site-regen
fi
}
@@ -84,5 +93,6 @@ pkg_postrm() {
if use emacs; then
xdg_icon_cache_update
xdg_desktop_database_update
+ elisp-site-regen
fi
}