summaryrefslogtreecommitdiff
path: root/dev-lang/mozart/mozart-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-lang/mozart/mozart-2.0.1.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-lang/mozart/mozart-2.0.1.ebuild')
-rw-r--r--dev-lang/mozart/mozart-2.0.1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/dev-lang/mozart/mozart-2.0.1.ebuild b/dev-lang/mozart/mozart-2.0.1.ebuild
new file mode 100644
index 000000000000..b44def58b107
--- /dev/null
+++ b/dev-lang/mozart/mozart-2.0.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils java-pkg-2 java-ant-2
+
+PATCHSET_VER="1"
+
+DESCRIPTION="Advanced development platform for intelligent, distributed applications"
+HOMEPAGE="http://mozart2.org/"
+SRC_URI="https://github.com/mozart/mozart2/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~keri/distfiles/mozart/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/gmp:0
+ dev-lang/tcl:0
+ dev-lang/tk:0
+ emacs? ( >=app-editors/emacs-23.1:* )"
+
+DEPEND="${RDEPEND}
+ dev-java/ant-core
+ >=virtual/jdk-1.8:=
+ dev-lang/scala:2.12
+ test? ( dev-cpp/gtest:= )"
+
+S="${WORKDIR}/${PN}2-${PV}"
+BUILD_DIR="${S}/build"
+CMAKE_USE_DIR="${S}"
+
+src_prepare() {
+ if [[ -d "${WORKDIR}"/${PV} ]] ; then
+ eapply "${WORKDIR}"/${PV}
+ fi
+ eapply_user
+
+ touch "${S}"/stdlib/CMakeLists.txt
+ touch "${S}"/vm/vm/test/gtest/CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DMOZART_BOOST_USE_STATIC_LIBS=OFF
+ -DEMACS=$(if use emacs; then echo /usr/bin/emacs; fi)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ EANT_GENTOO_CLASSPATH="scala:2.12"
+ cd "${S}"/bootcompiler
+ ANT_OPTS="-Xss2M" eant jar
+
+ cd "${S}"
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_compile vmtest platform-test
+ cmake-utils_src_test -V
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ cd "${BUILD_DIR}"
+ dolib.so vm/vm/main/libmozartvm.so
+ dolib.so vm/boostenv/main/libmozartvmboost.so
+}
+
+pkg_postinst() {
+ if use emacs; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use emacs; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}