summaryrefslogtreecommitdiff
path: root/dev-lang/micropython/micropython-1.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/micropython/micropython-1.9.3.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/micropython/micropython-1.9.3.ebuild')
-rw-r--r--dev-lang/micropython/micropython-1.9.3.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-lang/micropython/micropython-1.9.3.ebuild b/dev-lang/micropython/micropython-1.9.3.ebuild
deleted file mode 100644
index 672087758df5..000000000000
--- a/dev-lang/micropython/micropython-1.9.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Python implementation for microcontrollers"
-HOMEPAGE="https://github.com/micropython/micropython"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-DEPEND="
- virtual/libffi
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-prevent-stripping.patch" )
-
-src_compile() {
- cd ports/unix || die
-
- # 1) don't die on compiler warnings
- # 2) remove /usr/local prefix references in favour of /usr
- sed -i \
- -e 's#-Werror##g;' \
- -e 's#\/usr\/local#\/usr#g;' \
- Makefile || die
- emake CC="$(tc-getCC)" axtls
- emake CC="$(tc-getCC)"
-}
-
-src_test() {
- # XXX: find out why these tests fail
- rm -v tests/misc/recursive_iternext* || die
-
- cd ports/unix || die
- emake test
-}
-
-src_install() {
- pushd ports/unix > /dev/null || die
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" DESTDIR="${D}" install
- popd > /dev/null || die
-
- # remove .git files
- find tools -type f -name '.git*' -exec rm {} \; || die
-
- dodoc -r tools
- einstalldocs
-}