summaryrefslogtreecommitdiff
path: root/dev-lang/maude/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-lang/maude/files
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-lang/maude/files')
-rw-r--r--dev-lang/maude/files/maude-2.5.0-prll.patch24
-rw-r--r--dev-lang/maude/files/maude-2.7-bison-parse-param.patch39
-rw-r--r--dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch60
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-lang/maude/files/maude-2.5.0-prll.patch b/dev-lang/maude/files/maude-2.5.0-prll.patch
deleted file mode 100644
index 5499af3eb764..000000000000
--- a/dev-lang/maude/files/maude-2.5.0-prll.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/src/Mixfix/Makefile.am b/src/Mixfix/Makefile.am
-index d811631..295f0c6 100644
---- a/src/Mixfix/Makefile.am
-+++ b/src/Mixfix/Makefile.am
-@@ -72,7 +72,7 @@ libmixfix_a_SOURCES = \
- EXTRA_libmixfix_a_SOURCES = \
- compiler.cc
-
--BUILT_SOURCES = surface.yy surface.cc surface.h lexer.cc
-+BUILT_SOURCES = surface.cc lexer.cc
- CLEANFILES = surface.yy surface.cc surface.h lexer.cc
-
- surface.yy: \
-@@ -87,7 +87,9 @@ surface.yy: \
- $(srcdir)/bottom.yy \
- > surface.yy
-
--surface.cc surface.h: surface.yy
-+surface.h: surface.yy
-+
-+surface.cc: surface.h
- $(BISON) -dv surface.yy -o surface.c
- mv surface.c surface.cc
-
diff --git a/dev-lang/maude/files/maude-2.7-bison-parse-param.patch b/dev-lang/maude/files/maude-2.7-bison-parse-param.patch
deleted file mode 100644
index 2aa77f01c4e8..000000000000
--- a/dev-lang/maude/files/maude-2.7-bison-parse-param.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Author: Jakub Wilk <jwilk@debian.org>
-Last-Update: Tue, 20 May 2014 13:35:26 +0200
-Bug-Debian: http://bugs.debian.org/733407
-Description: this is quick and dirty patch to use %parse-param instead
- of deprecated YYPARSE_PARAM (and eventually removed in Bison 3.0).
- %parse-param was added in bison 1.875, over a decade ago, so no
- Build-Depends adjustments are needed. :-)
-
---- a/src/Mixfix/top.yy
-+++ b/src/Mixfix/top.yy
-@@ -24,6 +24,8 @@
- // Parser for Maude surface syntax.
- //
-
-+%parse-param {void* YYPARSE_PARAM}
-+
- %{
- #include <string>
- #include <stack>
-@@ -91,7 +93,7 @@ SyntaxContainer* oldSyntaxContainer = 0;
- Int64 number;
- Int64 number2;
-
--static void yyerror(char *s);
-+static void yyerror(void *, char *s);
-
- void cleanUpModuleExpression();
- void cleanUpParser();
---- a/src/Mixfix/bottom.yy
-+++ b/src/Mixfix/bottom.yy
-@@ -23,7 +23,7 @@
- %%
-
- static void
--yyerror(char *s)
-+yyerror(void *, char *s)
- {
- if (!(UserLevelRewritingContext::interrupted()))
- IssueWarning(LineNumber(lineNumber) << ": " << s);
diff --git a/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch b/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch
deleted file mode 100644
index b903d50e22bc..000000000000
--- a/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-https://bugs.gentoo.org/787851
-
-From 6d448928a88f586195dadd9fae9cb1b19e589d94 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Tue, 15 Jun 2021 03:05:34 +0000
-Subject: [PATCH] Fix build with GCC 11
-diff --git a/src/ObjectSystem/configSymbol.hh b/src/ObjectSystem/configSymbol.hh
-index 90b00d9..d037dab 100644
---- a/src/ObjectSystem/configSymbol.hh
-+++ b/src/ObjectSystem/configSymbol.hh
-@@ -50,7 +50,7 @@ public:
- private:
- struct symbolLt
- {
-- bool operator()(const Symbol* d1, const Symbol* d2)
-+ bool operator()(const Symbol* d1, const Symbol* d2) const
- {
- return d1->compare(d2) < 0;
- }
-diff --git a/src/ObjectSystem/objectMap.cc b/src/ObjectSystem/objectMap.cc
-index 0dbcaf0..722aa29 100644
---- a/src/ObjectSystem/objectMap.cc
-+++ b/src/ObjectSystem/objectMap.cc
-@@ -50,7 +50,7 @@ ConfigSymbol::MessageQueue::markReachableNodes() const
-
- struct ConfigSymbol::dagNodeLt
- {
-- bool operator()(const DagNode* d1, const DagNode* d2)
-+ bool operator()(const DagNode* d1, const DagNode* d2) const
- {
- return d1->compare(d2) < 0;
- }
-diff --git a/src/ObjectSystem/objectSystemRewritingContext.hh b/src/ObjectSystem/objectSystemRewritingContext.hh
-index 33785ec..32f4d94 100644
---- a/src/ObjectSystem/objectSystemRewritingContext.hh
-+++ b/src/ObjectSystem/objectSystemRewritingContext.hh
-@@ -62,7 +62,7 @@ protected:
- private:
- struct dagNodeLt
- {
-- bool operator()(const DagNode* d1, const DagNode* d2)
-+ bool operator()(const DagNode* d1, const DagNode* d2) const
- {
- return d1->compare(d2) < 0;
- }
-diff --git a/src/Mixfix/entity.hh b/src/Mixfix/entity.hh
-index eb8ad58..a221de4 100644
---- a/src/Mixfix/entity.hh
-+++ b/src/Mixfix/entity.hh
-@@ -53,7 +53,7 @@ public:
- private:
- struct UserLt
- {
-- bool operator()(const User* user1, const User* user2)
-+ bool operator()(const User* user1, const User* user2) const
- {
- //
- // Direct < comparison of unrelated pointers is undefined. But since the casting
---
-2.32.0