summaryrefslogtreecommitdiff
path: root/dev-lang/julia/julia-1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
commitfe618c8b8c934661d2297b2aeb0615a48e787691 (patch)
tree24a8209687e0ff34205acd703b6b80e7c6897f81 /dev-lang/julia/julia-1.7.3.ebuild
parent1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (diff)
gentoo auto-resync : 27:07:2022 - 03:00:38
Diffstat (limited to 'dev-lang/julia/julia-1.7.3.ebuild')
-rw-r--r--dev-lang/julia/julia-1.7.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/julia/julia-1.7.3.ebuild b/dev-lang/julia/julia-1.7.3.ebuild
index 39455ca05597..1b2d16111014 100644
--- a/dev-lang/julia/julia-1.7.3.ebuild
+++ b/dev-lang/julia/julia-1.7.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit llvm pax-utils toolchain-funcs
+inherit flag-o-matic llvm pax-utils toolchain-funcs
# correct versions for stdlibs are in deps/checksums
# for everything else, run with network-sandbox and wait for the crash
@@ -123,6 +123,9 @@ src_prepare() {
}
src_configure() {
+ # bug #855602
+ filter-lto
+
use system-llvm && ewarn "You have enabled system-llvm. This is unsupported by upstream and may not work."
# julia does not play well with the system versions of libuv