summaryrefslogtreecommitdiff
path: root/dev-lang/jsonnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-lang/jsonnet
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-lang/jsonnet')
-rw-r--r--dev-lang/jsonnet/Manifest2
-rw-r--r--dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild (renamed from dev-lang/jsonnet/jsonnet-0.17.0.ebuild)27
2 files changed, 18 insertions, 11 deletions
diff --git a/dev-lang/jsonnet/Manifest b/dev-lang/jsonnet/Manifest
index 69933f5f4adc..b21c33589fa1 100644
--- a/dev-lang/jsonnet/Manifest
+++ b/dev-lang/jsonnet/Manifest
@@ -8,5 +8,5 @@ DIST jsonnet-0.17.0.tar.gz 21854054 BLAKE2B 91561f2cffb5c711d4ba58aceef90bbcd654
EBUILD jsonnet-0.15.0.ebuild 1362 BLAKE2B c964f25e046778eebe7b12a3a9f72e057849c33a61b2bdfbc8e188000b4ecd81529000cc88abe04a69b440ced1ab9453bb1db462e5ae4ed7a72426e4d4f0ad3b SHA512 a4a3610b032b23d3a1344813233f174d90096a26d2fc13742b9509899267038bef5833b7c8f74ac4da7756e40378ca2def4fccde72144971b4edb63dea2f9f55
EBUILD jsonnet-0.16.0-r2.ebuild 1602 BLAKE2B d7ba07b9662666004038acb58c03c0d28363d9d6d97696b264660e4f1e447b17cde2a9e5a55745a6b27d1885fc8be653db971bb80404ef72dc2c388ab3ce0614 SHA512 4ef957e74620e6e8aed5ca5e02fc08bfc6bfd28d8ac091fe37a15790546f048a2eb5f2585958ea3672c2961bea22787349fdf53b4120f1e1a75ac5b040d95e6c
EBUILD jsonnet-0.16.0.ebuild 1378 BLAKE2B e8fc96ff886b9a5dc5897aa16217db15db8f1af1aeb53d14dbd0c2fb41f9dfa4dbb73ce3b1713a449d50b3118a15118fa3ce2b6a6b238e2eab437ff7189bf474 SHA512 e8756691fd5cfaff0f81cf499f909fe98eeb05a9951bb2a237cc4afad5d530042de88f914a0e971a44f17bfa3dcf733d77520b3a7760482a739026e43375b1dc
-EBUILD jsonnet-0.17.0.ebuild 1489 BLAKE2B 1b7074b2d42f0ffd14e09d07fe8964a48b631f443f5b9da3626060730e76ee19697502051c60c4f9acf12fe9d9331cac4bbcb95256ceddd0c71a273a6680f80a SHA512 b5aebc387ef33682fff935bc70ec99373fa59db490ef69e688a1aea4aa95610185955876adf27f1c455170d1edfd1701b739eacddadd392dddb40e22883cf58d
+EBUILD jsonnet-0.17.0-r1.ebuild 1753 BLAKE2B 8926b856d4206e4e6e877b3f93e393d8c456336e7f01ad99a3fc486e18c3cf8dbc52121440e3d6a686c251d890a11b78c86ee8ceabe16374be320c0351126faf SHA512 7166f16f6297ca3a8e96cd2e8c125797f93b9b63e7c25df554869efc2ac479e96a7a1d0269b97915c131e0b8fa228a612f453f0bc56db23d116b8f8e6f6f6cc5
MISC metadata.xml 621 BLAKE2B cf9e06f9981b454578c1769425dc15a7a271063b2a95c296db1326c4b4ce0f93ff96a2df42143d9d6fb8e1e196039a26119c35a4881c7d6b2241b58b01cdc948 SHA512 ea583ea6df7d0994e13bf01fff4b99b65ac288e734d41f52bffa4ae8a83d27196622074a6a29bfbbf190125a9cf29e6602f5b4a55ccec76c6324f3ac0b1f50ef
diff --git a/dev-lang/jsonnet/jsonnet-0.17.0.ebuild b/dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild
index 67a0000cab80..3faabad2b33b 100644
--- a/dev-lang/jsonnet/jsonnet-0.17.0.ebuild
+++ b/dev-lang/jsonnet/jsonnet-0.17.0-r1.ebuild
@@ -4,14 +4,14 @@
EAPI=7
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit toolchain-funcs flag-o-matic distutils-r1
DESCRIPTION="A data templating language for app and tool developers "
HOMEPAGE="https://jsonnet.org/"
SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization python"
+IUSE="custom-optimization doc examples python"
LICENSE="Apache-2.0"
SLOT="0"
@@ -34,6 +34,8 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}/jsonnet-0.14.0-makefile.patch"
"${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+ "${FILESDIR}/jsonnet-0.16.0-libdir.patch"
+ "${FILESDIR}/jsonnet-0.16.0-cp-var.patch"
)
distutils_enable_tests unittest
@@ -45,15 +47,12 @@ src_prepare() {
src_configure() {
use custom-optimization || replace-flags '-O*' -O3
+ tc-export CC CXX
default
}
src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
+ emake bins libs
use python && distutils-r1_src_compile
}
@@ -68,8 +67,16 @@ python_test() {
}
src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" \
+ CP="cp -d" LIBDIR="$(get_libdir)" install
use python && distutils-r1_src_install
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ docinto html
+ dodoc -r doc/.
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
}