summaryrefslogtreecommitdiff
path: root/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /dev-lang/jsonnet/jsonnet-0.20.0.ebuild
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'dev-lang/jsonnet/jsonnet-0.20.0.ebuild')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.20.0.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.20.0.ebuild b/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
deleted file mode 100644
index 8e5c294e6207..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_OPTIONAL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit cmake toolchain-funcs flag-o-matic distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers"
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization doc examples python test"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-RDEPEND="
- dev-cpp/rapidyaml:=
- dev-cpp/nlohmann_json:=
- python? ( ${PYTHON_DEPS} )
-"
-
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-
-BDEPEND="
- python? (
- ${PYTHON_DEPS}
- ${DISTUTILS_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
- "${FILESDIR}/jsonnet-0.16.0-libdir.patch"
- "${FILESDIR}/jsonnet-0.16.0-cp-var.patch"
- "${FILESDIR}/jsonnet-0.18.0-unbundle.patch"
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- cmake_src_prepare
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- use custom-optimization || replace-flags '-O*' -O3
- tc-export CC CXX
-
- local mycmakeargs=(
- -DUSE_SYSTEM_JSON=ON
- -DBUILD_STATIC_LIBS=OFF
- )
-
- if use test; then
- mycmakeargs+=(
- -DBUILD_TESTS=ON
- -DUSE_SYSTEM_GTEST=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_TESTS=OFF
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use python && CMAKE_BUILD_DIR="${BUILD_DIR}" distutils-r1_src_compile
-}
-
-src_test() {
- cmake_src_test
- use python && CMAKE_BUILD_DIR="${BUILD_DIR}" distutils-r1_src_test
-}
-
-python_test() {
- LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}" "${EPYTHON}" -m unittest python._jsonnet_test -v \
- || die "Tests failed with ${EPYTHON}"
-}
-
-src_install() {
- cmake_src_install
- use python && distutils-r1_src_install
-
- if use doc; then
- find doc -name '.gitignore' -delete || die
- docinto html
- dodoc -r doc/.
- fi
- if use examples; then
- docinto examples
- dodoc -r examples/.
- fi
-}