summaryrefslogtreecommitdiff
path: root/dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild b/dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild
new file mode 100644
index 000000000000..d4d1373fa872
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.16.0-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization doc examples python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 ppc64 x86"
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+ "${FILESDIR}/jsonnet-0.16.0-libdir.patch"
+ "${FILESDIR}/jsonnet-0.16.0-cp-var.patch"
+)
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ use custom-optimization || replace-flags '-O*' -O3
+ tc-export CC CXX
+ default
+}
+
+src_compile() {
+ emake bins libs
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" \
+ CP="cp -d" LIBDIR="$(get_libdir)" install
+ use python && distutils-r1_src_install
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ docinto html
+ dodoc -r doc/.
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+}