summaryrefslogtreecommitdiff
path: root/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-lang/jsonnet/jsonnet-0.13.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-lang/jsonnet/jsonnet-0.13.0.ebuild')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.13.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.13.0.ebuild b/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
deleted file mode 100644
index bb16ecea1cd1..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit toolchain-funcs distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers "
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="python? ( ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.12.1-makefile.patch"
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
- "${FILESDIR}/jsonnet-0.13.0-glibc-2.29.patch"
-)
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- jsonnet \
- libjsonnet.so \
- libjsonnet++.so
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
- use python && distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test || die
-}
-
-src_install() {
- dolib.so libjsonnet*.so
- dobin jsonnet
-
- use python && distutils-r1_src_install
-}