summaryrefslogtreecommitdiff
path: root/dev-lang/jerryscript/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-lang/jerryscript/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-lang/jerryscript/files')
-rw-r--r--dev-lang/jerryscript/files/jerryscript-2.4.0-no-werror.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/jerryscript/files/jerryscript-2.4.0-no-werror.patch b/dev-lang/jerryscript/files/jerryscript-2.4.0-no-werror.patch
new file mode 100644
index 000000000000..216e72758a25
--- /dev/null
+++ b/dev-lang/jerryscript/files/jerryscript-2.4.0-no-werror.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/840263
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -167,7 +167,6 @@ endmacro()
+ macro(jerry_add_compile_warnings)
+ foreach(_warning ${ARGV})
+ jerry_add_compile_flags(-W${_warning})
+- jerry_add_compile_flags(-Werror=${_warning})
+ endforeach()
+ endmacro()
+
+@@ -212,7 +211,7 @@ if(USING_GCC OR USING_CLANG)
+ jerry_add_compile_flags(-fno-builtin)
+ endif()
+ jerry_add_compile_warnings(all extra format-nonliteral init-self conversion sign-conversion format-security missing-declarations shadow strict-prototypes undef old-style-definition)
+- jerry_add_compile_flags(-Wno-stack-protector -Wno-attributes -Werror)
++ jerry_add_compile_flags(-Wno-stack-protector -Wno-attributes)
+ endif()
+
+ if(USING_GCC)
+--- a/targets/zephyr/Makefile.zephyr
++++ b/targets/zephyr/Makefile.zephyr
+@@ -55,9 +55,8 @@ EXT_CFLAGS += -ffunction-sections -fno-inline-functions
+ EXT_CFLAGS += $(KBUILD_CFLAGS) $(NOSTDINC_FLAGS) $(subst -I,-isystem,$(ZEPHYRINCLUDE))
+
+ EXT_CFLAGS += -Wall -Wno-format-zero-length -Wno-pointer-sign
+-EXT_CFLAGS += -Werror=format -Werror=implicit-int -Wno-unused-but-set-variable
++EXT_CFLAGS += -Wformat -Wimplicit-int -Wno-unused-but-set-variable
+ EXT_CFLAGS += -Wno-main -Wno-strict-aliasing -Wno-old-style-declaration
+-EXT_CFLAGS += -Wno-error=format=
+ EXT_CFLAGS += -D_XOPEN_SOURCE=700
+
+ EXT_CFLAGS += -Wno-error=conversion