summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-25 10:43:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-25 10:43:56 +0000
commit5d88bb472ef4d6659a423746d4f8717e55ffaaf5 (patch)
tree65d2bb8ba367a660de263455ccac7eabf5ccc5ab /dev-lang/ispc/files
parenta4a19f78acc305106f3b54bec9af212e38bfe7be (diff)
gentoo auto-resync : 25:01:2024 - 10:43:56
Diffstat (limited to 'dev-lang/ispc/files')
-rw-r--r--dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch16
-rw-r--r--dev-lang/ispc/files/ispc-1.19.0-gcc13.patch27
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch b/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
deleted file mode 100644
index 19a19e871ee7..000000000000
--- a/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -598,11 +598,8 @@ else()
- target_link_libraries(${PROJECT_NAME} pthread tinfo.a curses.a)
- else()
- find_package(Curses REQUIRED)
-- if (CURSES_EXTRA_LIBRARY)
-- # this contains the tinfo library, if found
-- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
-- endif()
-- target_link_libraries(${PROJECT_NAME} pthread ${CURSES_CURSES_LIBRARY})
-+ set(CURSES_NEED_NCURSES ON)
-+ target_link_libraries(${PROJECT_NAME} pthread ${CURSES_LIBRARIES})
- endif()
- endif()
-
diff --git a/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch b/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch
deleted file mode 100644
index e2bae38ae581..000000000000
--- a/dev-lang/ispc/files/ispc-1.19.0-gcc13.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://bugs.gentoo.org/895572
-https://github.com/ispc/ispc/commit/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9
-
-From ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9 Mon Sep 17 00:00:00 2001
-From: Luya Tshimbalanga <luya@fedoraproject.org>
-Date: Tue, 28 Feb 2023 17:20:21 -0800
-Subject: [PATCH] Fix build with GCC 13 and possibly Clang 15
-
-This fix add missing <cstdint> include to handle "uint32_t".
---- a/src/target_registry.h
-+++ b/src/target_registry.h
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2019-2021, Intel Corporation
-+ Copyright (c) 2019-2023, Intel Corporation
- All rights reserved.
-
- Redistribution and use in source and binary forms, with or without
-@@ -40,6 +40,7 @@
- #include "bitcode_lib.h"
-
- #include <bitset>
-+#include <cstdint>
- #include <map>
- #include <vector>
-
-