summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-lang/ispc/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-lang/ispc/files')
-rw-r--r--dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch b/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch
new file mode 100644
index 000000000000..127b7095a778
--- /dev/null
+++ b/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -530,11 +530,8 @@ else()
+ else()
+ find_package(Curses REQUIRED)
+ find_package(ZLIB REQUIRED)
+- if (CURSES_EXTRA_LIBRARY)
+- # this contains the tinfo library, if found
+- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
+- endif()
+- target_link_libraries(${PROJECT_NAME} pthread ${ZLIB_LIBRARIES} ${CURSES_CURSES_LIBRARY})
++ set(CURSES_NEED_NCURSES ON)
++ target_link_libraries(${PROJECT_NAME} pthread ${ZLIB_LIBRARIES} ${CURSES_LIBRARIES})
+ endif()
+ endif()
+